2.0.84 Nightmare upgrade

Current version: 2.0.80
Win 7
I got the popup about the update. Downloaded it and decided to install it on my PC’s. I always start on my notebook since I consider that a secondary PC. Did the install, when install completed Glasswire started up. Said it was attempting to connect to local server and couldnt, also said the glasswire service had stopped.
So I rebooted thinking thats what it needed. After reboot, got the same errors in Glasswire and now I had no internet and a couple other services would not start up.
I tried to uninstall glasswire by using its uninstall program and that didnt work. It was as if an invisible window opened, I wasnt able to click on anything. I could open my start menu but couldnt click on anything forcing a hard reboot. This issue only happened after I tried to use the uninstall.
This forced me to do something I havent done in over a decade, uninstall a program from safe mode. Its been so long since Ive been in safe mode I had to google what key it was. I uninstalled the program, rebooted and everything is back to normal.

This experience caused me to lose faith in this program. Will most likely uninstall it from all PC’s.

1 Like


Sorry for the problem. May I ask if you used a third party uninstaller, or did you go to add/remove programs? GlassWire has a driver and when third party uninstallers are used it will usually leave our driver running and cause this problem.

To upgrade to GlassWire 2 we recommend you install it on top of 1.X.

For anyone else having these problems please check this thread Upgrading to GlassWire 2.0, tips, tricks, bug reports, feedback, and fixes

No 3rd party uninstaller. The issue above was with the Uninstall in the Glasswire start menu folder. I tried Add/Remove as well and after clicking Uninstall nothing happened. When I clicked it again it said there was already a process happening. But after a while nothing.

1 Like

I had an experience identical to Anjoland’s “nightmare”.

Everything was OK running Glasswire, on Windows7-64. I got the notification for version 2.0 (, downloaded it, and installed it.

Simply installing 2.0 over 1.2, I got the “local server timeout” after 3 attempts. “Restarting” from the UI did nothing.

Went into services, it said Glasswire service was stopped. Clicked to start and got MS error
"Error 1068: The dependency or group failed to start". Researched that error and Implemented some corrections to 2 registry key values that had solved the 1068 error for others.

Uninstalled all the Glasswire(s) and removed all the folders. Retried install with “clean” option. Still, timeout after 3x tries.

Uninstalled 2.0 and reinstalled Glasswire is working properly again - like it was, to begin with.

It’s been years since I spent 4 hours trying to cajole/beg/coerce a new version of Any program to run on my machine.

If you don’t plan on discontinuing - I’m happy with this version.
It performs every function I expect of it.

No further responses or help. I also cant find this by looking at the list of topics. I see it says unlisted, is that your way of hiding issues?

An update will be out next week. Sorry for the problem.