Action! Mirillis can't launch, Firewall issue?

Hello,

after the brutal death of my ssd, I reinstalled windows 10. it was a clean installation, I downloaded version 2, and a capture software: Action! of Mirillis.

The problem is that when you activate the firewall (I tested the 3 modes) as soon as the firewall is on “on”, Action refuses to launch because it detects that the firewall blocks it…

I read that on an old version the bug was fixed but still have to shut down firewall to launch the capture software and restart it after (although before I reinstall my windows with a glasswire version 1. X I didn’t have this problem)

If it were possible to help me, that would be great!

Thank you in advance

jojoneil

@jojoneil

Sorry for the problem.

I have an idea on what could solve it using our new “profiles” feature.

First uninstall GlassWire using Add/Remove programs, then reboot. Next reinstall our latest version using the “clean” install option with the “reset firewall” option also checked.

Now, GlassWire’s firewall should be off by default under its firewall tab.

Next launch “Action!”. Did it work? Good. Let it appear in the firewall list, but don’t turn on the firewall yet.

Now use IE or another app and let it appear on the firewall list.

Now turn on GlassWire’s Firewall, but don’t change modes. Now launch “Action!”. Did it work?

Now save this profile under “Profiles” in the top middle of the Firewall screen and use this profile when you use the Action app.

If this doesn’t work let me know and I’ll see if we can do some testing on our end.

Thank you Ken_GlassWire for the quick response!
Unfortunately, even after doing the requested manipulation,“Action!” is only launched if the firewall is on “off”. :frowning:

@jojoneil

Where can we download this app and try it so we can fix this for you? Is there a free version we can test?

You can download this app here : https://mirillis.com/en/downloads/downloads_action.html
There’s a 15-day trial version normally

Thx a lot for your support

Hi, I have the same problem and I get error 101.
https://mirillis.com/en/products/tutorials/action-recorder-error-message-101.html
I tried to fix it, but i failed! Did u encounter this problem (if u had time to test) ? @Ken_GlassWire

@Atris

If you go to the top left GlassWire menu and choose “About” what version do you have? Is GlassWire in “click to block” or what mode?

I updated from 1.9… & reset the firewall and settings, Now I have Last version, 2.0.80, I’ll try to replicate my problem in vmware

@Ken_GlassWire I did a simple test, it was easy to replicate the error

wmware > with clean windows 10
install glasswire 2.0.80 > activate > set firewall ON > Ask to connect
Install Mirillis Action > start the app > works ok
restart pc > start the app > error 101

glasswire > set firewall ON > Click to block
restart pc > start the app > error 101

glasswire > set firewall OFF
start the app > works ok

glasswire > dezactivate glasswire > (windows firewall is ON)
start the app > works ok

@Atris

When you installed 2.0.80 did you use the options in GlassWire’s installer to reset it to defaults, and reset its firewall in GlassWire’s installer options also? We had a bug in the previous version.

Also, if you could go to your Firewall Control panel before reinstalling GlassWire and choosing “restore defaults” that would be helpful too maybe. Sorry for the problem.

@Atris
I already tried all of that stuff, on my main pc, & now again in the virtual machine

VM > with clean windows, open GlassWire 2.0.80 > set firewall off > exit > uninstall > Restart
open Mirillis Action > works ok > exit
Windows Firewall > Restore > Restart
i already tryed (install GlassWire 2.0.80 + reset firewall + clean install ) & it failed
i’ll try now ? install GlassWire 2.0.80 + reset firewall + clean install > start GlassWire > firewall is off
open Mirillis Action > works ok > exit > Restart
open GlassWire > set firewall Click to block > ON
open Mirillis Action > error 101

If u can, please test the app in a virtual machine? & tell me if u encounter the error?

There’s no rush, but if it’s a bug maybe can be fixed, for now I’m gonna disable the Firewall > open Mirillis Action > Enable firewall > & use the app this way

1 Like

finally I found a double solution: I switched to OBS studio with buffer (similar to timeshift) and went back to Glasswire 1.2.121 because the firewall is free, it’s sad but it works the time to wait.

1 Like

@jojoneil

If you could report this issue to Action!'s company also it may help. Thanks for alerting us to this issue.