After upgrade to "Elite" to use the mode "Ask to Connect" i cannot use the mode

The mode is available in the menu but when i activate it the firewall changes to “on”, after 2-3 seconds changes to “off”.
I tried to reinstall the programm and removed all Datat in c:\ProgrammData\GlassWire, the it worked 2- 3 minutes, asked some programmes to connect and then stopped working.
What´s the problem please?


Sorry for the problem. Could you go to add/remove programs and uninstall GlassWire, then go to your C:\ProgramData folder and remove the “GlassWire” folder then reboot?

Next reinstall our latest version and upgrade again and see if this problem continues. Thanks!

Hi Ken,

yes this worked. But GlassWire seems to have problems with programs running from network drives. Every program is reported, i click “Allow” and nothing is happen. When i copy the program to my desktop an start it, GlassWire aks me again, i klick “allow” and… it works. I tried 3 differnt programs. Every program loaded from server did not work with GlassWire activated.

Sorry, i have to revert. It is not working. I had to stop the Firewall because of the network programms. When i tried to restart the firewall i have the same effect, the firewall starts and then stops after 2-3 seconds…
really this cost me a lot of time an i cannot rollout the firewall in my office.
Can i have my money back please?
Seams GlassWire is too buggy for office use.

Lars, another user reported this to our helpdesk and we think we have fixed the problem. Please email us if you would like to try an updated version and include a link to this thread.

Sent an email to help@… waiting for respone :wink:

I responded, thanks!

Same problem here. Set firewall to “Ask to connect” and after 2-3 seconds changes back to “Click to block”

Tom, please email our helpdesk so we can send you a new version to test. Thanks.

A newer version then the one yesterday? the version did not fix my problem.

Lars, sorry I was replying to Tom above. He has a similar issue. I’ll reply to your email today with a way you can send us logs to help us find the problem if you don’t mind. Thanks for your patience.

found this thread 'cause I think I have the same issue. I apologize in advance: I’ve only spend a few minutes on this. I upgraded today so I can use Glasswire to selectively block traffic from using up metered bandwidth during a trip that starts tomorrow.
I set Ask to Connect, and it didn’t. Everything just kept working as normal.
Later in the day, a program I rarely use failed to reach it’s server. Ping also failed. Ping to also failed, yet web browsing and email were working. I turned off the Glasswire firewall and all was well. I’ve not yet tried unistall/delete/reinstall. But I see word of a limited release patch to fix it. I would be very grateful if someone could summarize the solution. If it matters: I’m on Windows 7 64.
ps: does someone know if this feature ‘Ask to Connect’ can be enabled only for specific (metered bandwidth) networks?
Thanks much!


Please email our helpdesk also so we can get some logs from you if you’d like to email them to us. Thanks!

Just to confirm (I think I was the user they mention who originally reported it): it was fixed for a while, but now, on a Win 10 system installed from scratch, it is failing again. Keeps disabling Ask to Connect no matter what I do.

After wiping both the storage.db and glasswire.db and reinstalling it seems to be working again for now. So, something in there seems to cause the hickups?

Similarly, on paid Basic version, ‘Ask to Connect’ does not ‘stick’. Always defaults back to ‘Click to Block’.
Win 8.1 64-bit.

We found this bug due to another user’s bug report and we will have an update out soon that solves this.

Same here, just bought basic, but Ask to connect and Lockdown mode don’t work… Win10 ENT version…

thnx for soon fix of this problem…

Thanks for reporting. Our update will be out this week.

Hi there,

when to expect the bugfixed version ?
Also bought basic version today, just to find out that “ask to connect” won’t work (Win10). :frowning: