Ask To Connect turning itself off

I have purchased GlassWire Pro for the “Ask To Connect” feature.
I can’t seem to keep “Ask To Connect” to stay selected.
It keeps switching itself back to “Click To Block” within a few seconds after selection, its quite annoying.

Any idea what’s causing this?

1 Like

This is a known problem due to a bug with an older version of GlassWire. Sorry about that.

Please go to add/remove programs and uninstall GlassWire, then go to
the ProgramData folder and delete the GlassWire folder, then reboot,
then reinstall and it should fix it.

I just encountered this same problem on Windows 7 with GlassWire version 1.1.41b.

@Ken_GlassWire: in what versions of GlassWire is this bug fixed? Or, if the fix has not been released yet, what is the ETA on the fixed release?

This bug has been fixed. Please do a clean install and as recommended above and if it doesn’t fix it please let me know.

1 Like

Version 1.1.41b is the only version of GlassWire I’ve ever installed on my Windows 7 system. Here’s what I did, nearly a week ago:

  1. Installed GlassWire 1.1.41b on Windows 7
  2. Activated my copy using the GlassWire Basic serial number that I had just purchased.
  3. I let it run for a day or so in the default “Click To Block” mode to accumulate expected apps in my Firewall list.
  4. Then I successfully switched to “Ask To Connect” mode. All was well.
  5. A couple days later, I decided to switch back to “Click To Block” mode for a while.
  6. Then, after a few hours, I tried to switch back into “Ask To Connect” mode. This is when the bug happened: now it always automatically switches back to “Click To Block” mode after a few seconds. I have no idea why.

Thus, I have reproduced this bug using a clean installation of the latest version of GlassWire (1.1.41b). I have tried rebooting but it does not help.

Please advise. The “Ask To Connect” mode is the main reason why I purchased GlassWire Basic in the first place. Thanks.

1 Like

@fjarlq Sorry for the problem. Do you use any other firewall software simultaneously with GlassWire? Can you try this?

  1. Stop the GlassWire service
  2. Remove the database (c:\programdata\glasswire\service\glasswire.db)
  3. Start the GlassWire service

If you’d like to join our testing list we have an unreleased version. Please email our contact page and make the subject “testing list”.

The only other firewall software I have is the Windows Firewall that comes with Windows 7. I haven’t changed it in months, and so it’s still enabled. (I assume that’s not unusual… it’s enabled by default on Windows 7, right?)

I followed the steps you outlined, and when I restarted GlassWire I noticed the apps listed on GlassWire’s Firewall tab had been reset. And sure enough, when I change GlassWire’s Firewall to “Ask To Connect” mode, the change successfully persists, so I guess the problem is somehow due to the input in my glasswire.db file.

I’ll request access to the unreleased version. Question: I kept my old troublesome glasswire.db file… would it be useful to try that bad input with the unreleased version? After upgrading to the test version, I could stop the service, install the bad glasswire.db, and restart the service. Would that be a valid, interesting test?

Another question: You said to “email our contact page”, but what does that mean? Email one of the addresses listed on your contact page? If so, which of the three listed addresses should I email?

@fjarlq Please email the helpdesk “help” email on the contact page. I don’t like to post that email in the forum because occasionally we change it due to spam and other users searching the forum will input the old email address.

The new version of GlassWire uses a different database format, and that new version will actually change your database to work with the new version when you install it so your test wouldn’t help unfortunately. Thanks for your offer though.


The same exact steps produced this issue for me yesterday. Now no matter what I do it seems it simply puts itself back into “Click To Block”. Seems to be a fairly decent sized bug for the amount of money people pay to have the product. I saw a topic here on the forums whispering an update maybe 2 weeks ago… we’ll see… as being told to uninstall then reinstall seems completely absurd.

I like Glasswire and all… but I would like it even more if a known bug such as this got addressed and I didn’t have to uninstall and reinstall any time I needed to perform a certain step.

I too will take part in the testing phase as I would like to see if there are any improvements.

Thanks for joining the testing. The “Ask to connect” feature is one of our more popular features and I have only seen this bug reported a few times. We had trouble recreating this problem on our end, but now we think we have it figured out. I hope to send out an update to text tomorrow or Wednesday.

1 Like


Hi, I seem to have the same problem. I am a customer since september 2015 and have used all versions of glasswire since. every once in a while it decides to switch back to “click to block” and stay there, no matter how often I reset it do “ask to connect”. the only thing that works is completely removing it from the system (uninstall, delete glasswire directory in programdata) but this is starting to get annoying, since I have to set up all my blocking rules from scratch each time I do this. I am currently using 1.1.41b and yesterday it happened again.

I also tried your workaroung @Ken_GlassWire which reset the software to the expected behaviour, but that still leaves me with no rules. it was also displaying a list of rules which were only labeled by seemingly random numbers.

I can only recommend my recommendations above. Meanwhile we will have a major new update out soon that should solve this for your permanently. Sorry for the problem.

I tried the above steps and I still connect select ask to connect and keep it that way without reverting back to click to block. Im running the latest version, i have rebooted, deleted the programdata folder, etc and no matter what it always reverts back. Please advise

It sounds repetitive in the forum sometimes, but please uninstall GlassWire, reboot (important), then reinstall our latest version we just released with the “clean” option in the installer. Let me know your results. Thanks.

Even if you did it once please try it again please.

I did exactly that multiple times. Uinstalled, rebooted and reinstalled. I tried selecting “clean” on one try and unchecking clean a 2nd time. I tried deleting the db file in the programdata folder. I even deleted the entire glasswire folder from the programdata folder. I’ve done it at least 5 times trying it slightly different with each installation.

@Brian_Wilk Do you use any other firewall software that could be conflicting? Can you go to the GlassWire firewall settings and reset your firewall to the defaults, then reboot another time?

I do have Sphinx FireWall10Control also running. I can disable that temporarily to see if that makes a difference. For sake of clarity and brevity I will perform the following steps.

Currently Glasswire is uninstalled and laptop is powered off.

I will power on laptop and disable Sphinx Firewall10Control. I will also verify there is no Glasswire in the ProgramData folder or in the Program Files folder.

I will install Glasswire with the “clean” option checked. I will then go into the Firewall tab and see if I can toggle the ask to connect and see if it remains on.

Thanks. We did have some older versions of GlassWire that did have this bug, but I haven’t seen anyone report this in many months.

it may be reproduceable by installing an older version and then installing the latest version