"Block All" shows obnoxious message at bottom right of screen

Other firewalls I’ve used when I turn off the Internet connection, will simply turn their icon in the system tray to red. Glasswire instead throws a large box on the screen and keeps it there. If I want to play a game without Internet connection, I can’t see the bottom right of the screen. Why not just change the icon in the system tray like everyone else? I know the Internet is blocked because I just turned it off. I don’t need a message window telling me that. I don’t have short term memory loss, at least not yet. LOL

1 Like

I’ve actually commented on this myself, in another post, partly because I’m in my late 50’s and am starting to experience “C.R.S.” syndrome! The biggest problem that I’ve experienced is when I shut off the computer with “Block All” on, then come back to the device a few days later and wonder why my Internet’s not working!
At that point, computer restarted, Glasswire not opened yet, there is no ‘obnoxious warning in the lower rt corner of the display’ to remind me why it won’t work, and that it’s not a modem or cable problem. So, however the warning is arranged, I wish it would show up automatically upon reboot with the GW app not needing to be opened. I think most of us can remember we’ve turned it off during the same session that we turned it off in. I also don’t think I am the only user that has shutdown his/her computer with the Internet block active and forgotten they did it, when they restarted it later.

@GWBushwacker

Very weird!!!

Is GlassWire not starting on startup at all with your PC? Are you using our latest version? We’ll try to reproduce this.

Please check your settings to be sure GlassWire is set to start on startup (it’s set this way by default actually).

Glasswire starts up when the computer boots up, but it does not “open”, so there is no box with a warning showing that “Block All” is active, on the display, but it is still active. I’ve actually had this happen enough times now that I do know to suspect that I left it in that mode and chk GW first, but the first time it happened and another time a few months later, had me checking cables and rebooting router/modem, etc.! ;-))

1 Like

I’ve used other firewalls and when I can’t get out on the Internet, I check the system tray for a disabled/red icon which clues me in. I click on the icon and re-enable the firewall. Like you suggested, a popup message at boot-up when Glasswire has the Internet blocked would be nice too.

“then come back to the device a few days later and wonder why my Internet’s not working!”
I think that’s why 3M invented posted notes; for people like you and me. ROFL

1 Like