Cannot access NAS

So i got the GW basic license today

Currently setup as Ask to connect. Loving the product so far.

However i cannot access my NAS via DNS name or IP. Looking through
i found the app/service in Graph - Traffic but i have no option to allow. it.

The only way to access my nas is change Firewall to click to block.
The Service is MS-DS Active Directory, Windows Shares

Is their a way to whitelist an IP/Name or Service+ IP?


Same issue here on my main pc.
I installed glasswire on my laptop without any issue with the same Synology NAS.
I guess something is being blocked for my LAN but i can’t figure what’s the difference between my laptop and my desktop (except the Wifi and rj45).

If I switch off glasswire the connection to my NAS is back obviously.

Thanks anyway for this awesome piece of software i’m looking forward to the upgrades, in the mean time i bought glasswire :wink:


Reported to the dev team, thank you.

If you are having this problem is your Host process for Windows Services marked as allowed on the firewall? Please confirm.

The only thing blocked is skypehost

As I said previously
ask to connect - does not work
Click to block - does work

If it was blocked both would not work?

Thanks. Our dev team asked me to ask you this to be sure. I’ll let them know the answer.

Just to add extra info as I used to be a software tester myself.

IP range for has 1.1.1.x
Nas is password locked

In click to block mode nas works correctly

In ask to connect mode. No popup appears to allow to connect,
Windows then shows the standard cannot connect to device message.

I will send you a new version that should fix this to test. Thanks for reporting this.

replied to your message :slight_smile:

1.Uninstalled & deleted "Program Data"
2. Reinstalled
3. tried to activate. "Activation server could not be contact x3"
4. 4th attempt worked
5. set Firewall to ON & "Ask to connect"
6. NAS Now works correctly.

Might be worth adding a export your firewall rules option as i thought program-data would only remove Graph data not firewall data also. i thought firewall data was stored in %appdata%

Thanks! I’ll forward your findings to our dev team. Sorry for the confusion on the firewall rules/data.

on a side note it does not actually ask to allow. is this correct. it just allows it without a popup.

is this correct?

We’re still working on the update before it’s available for the public. I’ll let the team know about no alert/ask dialog. Thanks!

no problem just wanted to point it out :slight_smile:

1 Like

Same problem here (02 03 2017)

Could you plese help me what was the solution to this problem? Thanks, Zoltan


Please upgrade to our latest software. Are you using “Ask to connect” mode and “NAS” does not ask you for permission? If you go to the Firewall tab can you unblock it there or is it not listed?