Cannot deactivate


#1

I’m trying to deactivate Glassware, because I need to reinstall my PC.

But after I select “Deactivate Glasswire” menu item, it restarts it, and still is activated. Deactivate menu is still active and all functionality that requires activation works.

How can I deactivate it?


#2

@mmozeiko

Sorry for the problem. Has GlassWire blocked itself from accessing the network? If you unblock it does it help?


#3

I have turned off Windows firewall (and GlassWire is OFF in firewall tab) and tried it again - same result.


#4

Sorry for the problem. Please continue on and if you run into any problems on the new PC when activating email us https://www.glasswire.com/contact/ and I’ll reset your code. I’ll be online at my PC for the next few hours so if you want to email me right now I can reset it for you instantly.
@mmozeiko


#5

Ok, I’ll reset the code when I’ll do the reinstallation. Thanks.


#6

Same problem I’ve been having, ad infinitum, ad nauseam.


#7

@dctrivandian

Did any of the suggestions above make any difference? Do you use any other third party security software that could be blocking GlassWire somehow from accessing the network? If so can you white list us?


#8

Yes, I use a plethora of other third-party security software programs; they are such a well-kept secret with me, that I would have to shoot you if I revealed them all to you. However, after reading through the suggestions here, I decided to do a thorough “roto-rooter” of my system to expunge any remaining traces of your software, and proceeded with a clean install with the latest version. That seems to have done the trick.


#9

Sorry to bring this up again, but I also cannot deactivate… Window opens up again with a fresh “Deactivate GlassWire” Button. Uninstalling doesn’t do the trick, turning of the firewall first (so that GlassWire definitely has internet access) doesn’t change anything either.


#11

Here is how to backup your GlassWire Database/settings before making these changes, just in case: https://www.glasswire.com/userguide/#Backup_Settings


#12

After uninstalling I did a local search for Glasswire, and deleted all folders in programs, app data, etc.

Works now.


#13

Same Here, wanted to deactivate my Glasswire to change my key after your upgrade, but it’s the same. Even tried by deactivating every firewall, Windows and glasswire.
Would you please fix this in the next update ?


#15

Here is an easier solution for everyone:

Please right click the Windows taskbar and choose the task manager, then find “GlassWire” under services and stop the service temporarily (by right clicking it).

Next remove the file license.dat from the C:\ProgramData\GlassWire\service folder.

Now restart GlassWire at the top left menu by exiting it, then restart the GlassWire service. Now try activating.

You can also back up your settings/history in advance if you want: https://www.glasswire.com/userguide/#Backup_Settings


#16

Doesn’t this require contacting support to reset activation info? I don’t think this is acceptable solution.


#17

@mmozeiko

No it should not require contacting support to do anything. But if you have to, I’m literally answering all support emails right now so I’m here to fix the problem.

I also messaged you privately here in case you need some help?


#18

Okay. Deleting the licence.dat perfectly worked, thanks.
I have another silly question, since I have used the elite offer, does it means I have now 2 licences ? My Elite + Basic ? Like 10+1 computers ?


#19

@Fl4v1en

That’s correct, you can use your Basic license also. Thank you for upgrading.


#20

Experienced this issue as well. Thanks for the solution!