Cannot Install v2.1 to Existing Location


#1

I am writing more in the hope that a correction will be made so that I can install GlassWire where I want and where it worked until today, than in asking for immediate help.

I just downloaded and attempted to install version 2.1.152. The previous version was on my SSD (D:). The installer noted this and attempted to re-install on that drive. I got an error message that the file gwdrv.sys could not be copied. The source file c:\windows\system32\drivers. The file is present in that location. If I cancel and try the install without the file, GlassWire cannot contact the local server and will not start.

I gave up and installed this version on my C: drive without issue. I do see my existing data, so that is not an issue.

Any thoughts on how I can reinstall on the D: drive? Manually copy the file after the installation?


#2

@abberow

Do these instructions on how to move the GlassWire database (to a non-SSD drive) help?
https://www.glasswire.com/userguide/#Moving_Database

Are you saying you moved the database to a non-SSD drive, then when you tried to upgrade you could not do so?


#3

Thanks for the quick response.

No, I tried to install the update in the current location, on the D: (SSD) drive. When that failed due to not being able to copy the driver, I tried the install on the C: (non-SSD) drive. It succeeded with no loss of historical data. I prefer to install on the D: drive some time in the future.


#4

Our team will discuss this issue and see if we can recreate it and fix it.

Unfortunately I do know the installer tech we use has some limits, so I’m not sure if it’s technically possible. You may have to just backup your database, then move it around after updates for now.

Instructions for backing up or moving the database are here:
https://www.glasswire.com/userguide/#Backup_Settings


#5

Thanks for getting back. I am at a loss to understand why we are discussing the database; perhaps it is my lack of understanding of how GlassWire is structured or how you use the term, “database”.

Let me provide more history. When I first put GlassWire on this PC, I placed it on the D: (SSD) drive to allow faster access. It installed and operated properly on this drive until the last update, 2.1.152. In this update, the installer could not find the driver gwdrv.sys in its expected location - c:\windows\system32\drivers in order to copy it to the GlassWire drivers sub-directories. It is in this folder. When I skipped installation of the driver, the installation completed, but GlassWire could not contact the local server and could not run.

When the installer was pointed to the C: drive, the driver could be found, the installation completed, and GlassWire is operating. It does not appear that records from before the update were lost.


#6

Oh, sorry!

It’s common for people to move GlassWire’s history database around to different hard drives so that’s why I assumed you were doing that. I should not have assumed that though, sorry.

Now I understand your issue better and I’ll share details with our team. Thanks for your report.


#7

Thanks. Do not treat this as critical as I have a workaround. Please let me know if you would like me to try anything to get you more information.


#8

i think the installer is trying to copy the file from the windows driver folder to the windows driver foolder itself and not from the installer exe

copy window shows the destination folder
and the error shows the same folder to copy from i think

edit: install an old version and then the new one has it fixed for me


#9

@playprogramm

Thanks for the details! So, for you, our newest installer is working correctly?


#10

playprogramm may be seeing a different issue, if an issue was even experienced. From what I can see from the screen shots, the installer does (and should?) copy the driver from the Windows drivers folder to the GlassWire driver folders. In my case, the copy failed because the installer could not find the driver. I presume the driver is copied because it is needed locally and is easier to copy than require the installer to contain and figure out which of many possible drivers to use.

As an experiment, I tried to install on my D: drive again. It worked. The entire GlassWire folder on my C: driver was removed. I renamed the drivers in both driver folders, though the uninstall likely made that moot, and tried again.
image

Once again, it worked. To recap, yesterday, I tried several times to do the upgrade to the D: drive, failing each time because the driver could not be found in C:\Windows\System32\Drivers. I installed on the C: drive without issue. No data was lost. Today, I tried reinstalling on the D: drive and experienced no failure. I did not reboot my PC between attempts.

My thought is that, unless playprogramm had a failure or you hear from others, the ticket is closed. This may have been temporary glitch. It cannot be recreated to collect information to correct. We cannot know whether it was an installer issue or an OS issue.

I appreciate your help and your quick responses.