Can't start GlassWire service since major 2.x update


#1

Since version 2.0.78 from december 2017 GlassWire can’t connect to local server and therefor I can’t use the program. I tried every version, including latest 2.0.115. During the last steps of installation ist says:
Installing service - done
Starting service - failed
After that the program tries to connect to local server > attempts 1-2-3 > ‘The GlassWire service stopped running’.

I considered many tipps from similar posts like ‘clean install’, ‘restore windows firewall settings’, deleting files and restarting. I also can’t start ‘GlassWire control service’ manualy in Windows services. Error code 1068.

Has anyone foud a solution for the problem?


#2

@fireWalt

Can you try installing our latest update with the “clean” install option checked? Please confirm.


#3

I already clean installed the last version 2.0.115. Same result as previous versions: Can’t start GlassWire service / Can’t connect to local server.


#4

@fireWalt

Are you seeing any .dmp files on the desktop?


#5

No .dmp files on my desktop.


#6

@fireWalt

Could you email us some logs? Here’s how to do it.
https://www.glasswire.com/contact/

  1. Stop the GlassWire service with the task manager;
  2. Create a log.conf text file with notepad and place it at C:\ProgramData\GlassWire\service
  3. Start the GlassWire service;
  4. Reproduce the problem;
  5. Send us the logs folder C:\ProgramData\GlassWire\service\log

The log.conf text file should have this text in it and should not end in .txt:

log_path=c:\programdata\glasswire\service\log
log_level_file=-1

Please note in your case, the service will not start so you shouldn’t have to start/stop it, but you can create the log file then install GlassWire over itself to recreate the problem, then send us the logs when the service fails to start.

Thanks!


#7

:star2: Solution :star2:
Thank you for all the answers, but after reserching again I found the solution for the problem in my case!

Under windows services > GlassWire control service > properties > dependencies
I saw, that GlassWire needs the service ‘Automatic WiFi configuration’ to work. This service was disabled, because I only use LAN on my PC. I set it from disabled to automatic and now the GlassWire service can start.

Maybe I could help someone with a similar problem.