Can't start GlassWire Service

@mitheshge

If you go to the WIndows Task Manager, then “Services” and try to start the service manually, does anything happen?

Also, you do not use a third party uninstaller, correct? These third party installers don’t stop our driver so it can cause this problem to exist.

Same problem here too. In every restart of the PC is not activated, nor can I do it from the application or from Windows services. However if I do right button and I give “close”, then rerun the program and starts correctly

Edited:

A completely clean installation seems to work:

Uninstall from Windows Panel
Restart
Delete Program Data and User-Appdata-Local folders

Install, re-enter the license in my case and restart again and Glass Wire works well

I do have a third party uninstaller. But I hardly use it. I only uninstall via control panel>uninstall.
First time when I restarted it, gw started automatically. second time i gave a restart via services>restart in task manager. and it completely stopped. Third time, restarted it, it said running but I had to manually press connect to make it work. Below are the screenshots.

Actually when i tried the clean install it worked for me too. I don’t need my settings. i can set it up again. But unfortunately I need all my graphs back. That’s the reason I have to restore it back.

1 Like

Fortunately I had the setup of GW 2.0.80. Glasswire 2.0.80 works super fine. No issues at all. Automatically starts up after a system restart. services start normally. But each restart you will get a notification about updating to 2.0.84. But ignore it.

For anyone having this issue, Follow the same steps to backup and restore if required. keep in mind that there are three restarts inbetween these steps.

For backup.
uninstall
-Rename C:\ProgramData\GlassWire folder to C:\ProgramData\GlassWire.bak
-Rename %USERPROFILE%\AppData\Local\GlassWire folder to %USERPROFILE%\AppData\Local\GlassWire.bak
-Restart
-installed gw with clean install and reset firewall option checked.
-start or do not start gw. doesn’t matter if you are restoring.

For restoring
-Uninstall
-Remove the existing C:\ProgramData\GlassWire folder
-Rename C:\ProgramData\GlassWire.bak folder to C:\ProgramData\GlassWire
-Remove the existing %USERPROFILE%\AppData\Local\GlassWire folder
-Rename %USERPROFILE%\AppData\Local\GlassWire.bak folder to %USERPROFILE%\AppData\Local\GlassWire
-Restart (use this restart if required.Not compulsory)
-install without the clean install and reset firewall option.
-DO NOT start GW. Uncheck the start GW.
-Restart again (for me this worked)
After your restart, you don’t have to open GW. it automatically starts all GW services including your graphs, activation(key) if applicable, without any problems.

I do not know what bug is it. But I guess I need to wait for an answer or another update.

*** Do not update to 2.0.84 if you have this issue. 2.0.80 works awesome. Tried multiple times to install and uninstall both versions including the restarts which I have mentioned. Only this above step worked and starts up properly.

@mitheshge

It’s great this solution works for you and thanks for the details. In case anyone else is considering downgrading to 2.0.80, our GlassWire service for GlassWire 2.0.84 is identical to the service for GlassWire 2.0.80.

Also I work the helpdesk and I haven’t seen .84 users having this problem.

So for other users, it’s probably not best to seek out 2.0.80 because it will most likely not make any difference for most people.

We’ll try to figure out why this happened for @mitheshge so we can recreate it and make sure it does not happen again. Sorry for the issue.

I also have this issue which I created another thread for which has since been forgotten.


With my issue in addition to the service issue, it killed my internet and messed with a couple other services. As soon as I uninstalled, my internet and the other services were fine.
I feel like there should be a .85 with a fix already.

Yes. Right now using the 2.0.80 v. And it works fine. Have no problems. But yes, need to be rectified soon.

The new update fixes the issue. v2.0.91 fixes the GW service crash on system startup. Thanks a lot @Ken_GlassWire for helping out.

1 Like

@mitheshge

Thank you for helping us find this problem.

The update is here for everyone.

Hello

I regret to say that the problem continues in this latest version 2.91.

Update two PCs and both the problem back again.

The option is right button and press exit and rerun it, of course, not to re-install everything again

@miguelgrado

Are you getting any .dmp files that appear on your desktop that you can send to us? Thanks.
https://www.glasswire.com/contact/

No,no file .dmp in dektop…sorry

Same issue here. 2.0.91 breaks the install, reboot does, uninstall reinstall, does not fix and the service keeps crashing. Tried the backup and restore posted, however that also failed to work. Cant locate an older install, so basically I have to lose my historical data or stop using the service.

VERY DISAPPOINTED!!

Followed the instructions provided by @mitheshge to the letter (twice) but for 2.0.91 it does NOT work for me at all I am dead in the water, service is stopped and cannot be run, click restart service and it just say attempt 1, 2, 3 nothing!!! :frowning:

So I assume I have to wait for an update or lose my historical data?

It can be forced to start (or try and start up and it starts to display) monitor the service you can see it starting to increase memory usage and CPU usage, but then all of a sudden a second GWCTL process starts and the app fails out (loses connection to local server) and requires the service restarted, rise repeat over and over.

@Ken_GlassWire I am getting dump files but they are 250MB a piece so cant email them and didnlt see anything else on that page you linked.

@James_Fleming I had this issue in the 2.0.80 ver. and continued to use it until this update. When I installed 2.0.91, It worked super fine. Absolutely no issues. I restarted it at least 4 times at various intervals to make sure it worked alright. And it did until yesterday. The issue seems to be there even in this version @Ken_GlassWire . Again I tried my usual steps of Back up and Restore, clean install etc. Clean install works. But if I need my graphs back, its becoming a mess. And this time its not always. For ex. Yesterday I had this issue. I restarted a couple times to check. And It was not working. But now as I am writing this, my GW suddenly started fine during startup. And there are no dmp files on the desktop.
Any idea as to whats causing this?
@James_Fleming I do have the setup’s of the older versions just in case if you want them. But as Ken said, no point going back to the older versions as they have more issues.
2.0.80 has issues with windows defender blocking the firewall rules.
2.0.84 and 2.0.91 has the same issues - Doesn’t start up with system and service keeps crashing.
I have all three setup files if in case you need it.

@mitheshge

Can you email us with a link to this thread?
https://www.glasswire.com/contact/

I can send you some instructions on creating logs so we can investigate how this is possible, thanks.

@mitheshge Yes I finally gave up keeping the historical; data and just did the clean install.

It seems that the problem occurs when you restart the PC, but in some tests I did, if I turn off and restart, the program works well