Click to Block pulldown unselectable /Update check for an app fails


Do you use another firewall software besides ours by chance? Usually if our firewall is not working it will give the other app name that is blocking it.

May I ask what other security software you use?

Would you consider clearing your firewall rules and trying a clean install? Please confirm and I can provide instructions.

Other than perhaps Windows10 firewall that is it security wise I use Eset Antivirus and Malwarebyte Anti-Malware.

Is there anyway of backing up these settings so that I can restore them should the clean install not solve the issue?


Before we do a clean reset, I was curious if your ESET version uses their own firewall or not? I found this page with information.

I also found this page

We use the Windows firewall API for blocking. If another security software is blocking us from using it then we cannot block and that would explain why your firewall is set to off. Usually GlassWire can detect this and tells which app is causing the issue and this error appears on the firewall screen.

Malwarebytes should have no issues with GlassWire.

No this is strictly Eset NOD32 antivirus only no firewall in the product at all.


Have you installed or tried any other firewall-related software recently? It’s not usual for our firewall to just not turn on at all.

With the Windows Firewall API is very reliable and relatively simple. It’s quite strange it would not turn on at all unless another app may have modified the API rules or settings somehow.

You mention you want to back up your rules. Did you modify the Windows Firewall manually at one point and is that what you want to back up, or do you just want to back up GlassWire’s rules?

I would not recommend backing up GlassWire’s rules because something is clearly very wrong here and it’s probably due to the rules with Windows Firewall.

I just wanted to back up Glasswire rules. I have been down this road before with Glasswire when I was using the free version of the product 3 years ago. That was on Windows7 on another computer and I wiped out Glasswire rules and it did not help the issue. I gave up and uninstalled the free version at the time

Personally do not think I ever used any firewall product on this Windows10 computer.

Well this morning I booted up the computer used it for 3 hours then decided to check GLasswire and discovered the Firewall was turned off. No amount of clicking on OFF toggle would turn it on. Rebooted the computer and the Firewall is now on.

If everything is working now then I’d leave it alone. If you want to reset everything related to the firewall you should do the following:

  1. Uninstall GlassWire in add/remove programs.

  2. Go to the Windows Firewall control panel and choose “restore defaults”.

  3. Reboot

  4. Install our latest version and choose “reset firewall” in the installer as an option.

This will keep all your other GlassWire settings, but reset your firewall. If the problem continues then it’s most likely something wrong with the Windows Firewall API itself (which is not something I see very often). I’d recommend running Windows Update and see if there are any updates available if you can.

I think I will reset everything because like yesterday on boot up this morning the Glasswire firewall was disabled completely and could not be turned on

I wish I could suggest another solution but this is an unusual problem. I follow all support for GlassWire and nobody else has reported this, unless they are using two firewalls or using an antivirus that disables the Windows Firewall API. In those cases there is usually a setting with the antivirus to use the Windows Firewall API.

If the problem continues after the reset please let me know and we can provide a version of GlassWire that has logging. We might be able to find the cause of this with detailed logs.

I did the uninstall. I told Windows Firewall to reset to defaults. Rebooted and during the reinstall told Glasswire to do a clean install. Firewall was enabled. Rebooted machine and checked and the Firewall was again disabled on reboot.

P.S. Rebooted a 2nd time and still can not get Glasswire Firewall enabled.

OK. I will let our team know about this issue and I’ll probably message you privately for next steps (most likely a logging version).

Interesting. I went into Services tab under Task Manager and restarted GlassWire service and the Firewall in GlassWire became enabled.


Do you see any .dmp files on your desktop? If so our service crashed and that .dmp file would give us details on how and why.

You could email us the .dmp using a cloud service like Dropbox or Google Drive.

Sorry no .dmp files on the desktop here. By the way the service was running before I restarted it and got the firewall running.

1 Like

I hope the situation is fixed permanently with the restart. Thank you for trying that.

Personally I doubt it since I rebooted Windows10 here probably 6+ times today and it was hit and miss on whether the Firewall became active. It was more deactivated than anything after all those reboots. If it was a service issue then FW should of been solved after the first reboot. At least for now I have a way of re-enabling the firewall. I wonder if I change Glasswire service to Delayed-Start in services would help at all? Perhaps this computer has an issue with all the services starting up at the same time.

I have never heard of delayed-start solving something with GlassWire but I don’t think it can hurt.

Meanwhile we have a ticket open with our team on your issue. I will let you know what they want to know next. Thanks for your patience.


Our team said if you would turn on logging and recreate the issue then it might help us find the problem.

How do I turn on logging?

  • Stop the GlassWire service with the task manager under “services”.

  • Open the file: C:\ProgramData\GlassWire\service\glasswire.conf as administrator with Notepad.

  • Set parameter LogEnabled to “true” and save changes.

  • Start the GlassWire service again by right clicking under the task manager and services.

When the issue shows up again please send us the logs from C:\ProgramData\GlassWire\service\log as soon as the issue is reproduced. You can message me privately in the forum if you prefer, or email us

If you email please provide a link to this forum thread so I know what the logs are about. Thank you for reporting this issue.

Yesterday I changed the startup of Glasswire service to delayed startup. This morning when I booted up the Glasswire FW was on and working. I feel I should keep an eye on it for now and if it starts misbehaving then I will follow the logging instructions.