Conflict with Backblaze (solved)

Hi there,

I’m having problems using Backblaze with Glasswire running. I’ve gone into the Windows firewall and set exceptions for all processes I can find for Backblaze, but it seems Glasswire is still blocking it.

If I restart, disable Glasswire, and reinstall Backblaze it works until my next restart and then stops connecting again.

Any assistance you can provide would be greatly appreciated.

Thanks!
Celeste

I did some research in the forum and found some people have used Backblaze and GlassWire together.

If you go to GlassWire’s firewall and switch the firewall to “Off” does Backblaze work, or not? If our firewall is off and Backblaze still does not work then the problem may not be related to GlassWire.

In what GlassWire Firewall mode are you in? “Ask to connect” or another?

Hi Ken,

Glasswire is generally set to “Ask to connect” on my computer and I need it to be set that way.

If I set the firewall to off and reinstall Backblaze, it works as I described (until next restart). It seems to me that something in Backblaze is getting blocked by Glasswire on first connection attempt without notifying or asking to connect. Then after that Backblaze no longer connects until I do the reinstall trick.

Sorry about the problem.

If GlassWire’s firewall is set to “Off” under the firewall tab, does Backblaze work then? The answer to that question helps me know what to suggest yet. Sorry for any confusion.

If I simply set the firewall to “Off,” Backblaze does not resume proper functioning. In order to get it to work again, I need to restart, and set the firewall to “Off” before Backblaze connects or it will be blocked until next restart.

@embryomedia

Could you try this for me? It may solve the issue.

  1. Uninstall GlassWire in add/remove programs.

  2. Please go to your “Windows Firewall” control panel and choose “restore defaults” if you can.

  3. Reboot - IMPORTANT!

  4. Reinstall GlassWire using its “clean install” option in its installer, plus “reset firewall” option.

  5. Don’t touch anything on GlassWire at all, then try to use Backblaze. Is it working?

  6. Now try turning on GlassWire’s Firewall and leave it on “Click to block” mode. Is Backblaze working?

  7. Now try turning on GlassWire’s “Ask to connect” mode if you need it. Do you get a connection request from Backblaze, or no?

Thanks

Hi there,

I followed your directions and everything appears to be working fine now. Thank you so much! :slight_smile:

2 Likes

@Ken_GlassWire I’m now having this same problem that @embryomedia had. I followed the steps you provided previously in August 2018, and Backblaze started working again; however, it stopped working today. I think there is something wrong with how GlassWire is interacting with Backblaze’s processes running in memory, because even if I turn GlassWire “OFF”, and then I try to resume my Backblaze backup, Backblaze still isn’t able to run successfully.

Here are a snippet from my Backblaze logs, which makes it seem like Backblaze isn’t able to connect to URLs that I’ve already allowed it to connect to in Glasswire: gist.github[.]com/p4gs/7255eaffbe1701cad6558a71f5bd7b5f (copy and paste this and then remove the brackets before “com”)

Here is log data from my Windows 10 event logs that correlates with Backblaze not being able to connect to its servers - it’s an error with Schannel that seems to have something to do with the HTTPS certificate (issued to *.backblaze.com) that Backblaze is asking Windows to validate when it goes to connect to its servers: gist.github[.]com/p4gs/c2b13044830a5299cd629777e4d7b55a (copy and paste this and then remove the brackets before “com”)

@p4gs

If GlassWire has a clean install and its firewall is set to “off” then it does not touch the Windows Firewall API at all.

I’d recommend uninstalling GlassWire, then going to your Windows Firewall control panel and choose “restore defaults” then reboot, then reinstall GlassWire using its “clean install” and “reset firewall” option.

Now try to recreate the issue.

GlassWire does not interfere with https certificates but some antivirus apps actually do kind of a “man in the middle” system with https. For example Kaspersky can do something like this in some cases.

Thanks for the response, Ken. I had already tried a full uninstall, “restore defaults” on Windows Firewall, and a full fresh reinstall of GlassWire. I also did the same thing for Backblaze. I’m continuing to have this issue. The only antivirus software running on my computer is Windows Defender. I have the latest Windows updates installed.

Are there any GlassWire logs I could examine that might reveal if GlassWire is causing issues for Backblaze?

@Ken_GlassWire For what it’s worth, I just did the following steps to rule out which things on my computer are interfering with Backblaze:

  • Disable Windows Defender fully (Backblaze still didn’t work)
  • Disable Windows Firewall fully (Backblaze still didn’t work)
  • Disable GlassWire’s firewall fully (Backblaze still didn’t work)

I did all of these things individually and all together at the same time. I also made sure to stop the Backblaze service and kill all running Backblaze processes. Backblaze still didn’t work after taking all of these steps individually and in combination.

Finally, I re-enabled all of the above features/software. Backblaze still didn’t work. Then I uninstalled GlassWire and restarted my computer. Backblaze started working again. Windows Defender is on and Windows Firewall is on (I did not restore my firewall settings to their defaults - old GlassWire firewall rules are still present in it).

I have a strong hunch that GlassWire is doing something else that interferes with Backblaze. Think about it: GlassWire is monitoring all network traffic connections that are associated with running processes, and it prompts users to Approve/Deny connections being attempted by processes. This makes me think that GlassWire is hooking parts of Windows OS that could potentially interfere with running processes’ network connectivity, even before GlassWire updates Windows Firewall’s rules.