Constantly very high CPU

Just bought Glasswire and while I love it, I’m close to trashing it. The reason is that I have a constantly high CPU usage of around 30% to 50%. My t460s churns on the fan for minutes on end.

This is with the official download from the website. I read to use a glasswire.cond file with “enable_network_scan = false” but that didn’t help much. I also disabled monitoring of webcam and mic.

Any help greatly appreciated.


Are you in “Ask to connect” mode, or what firewall mode?

Are you using Bittorrent or any unusual software that contacts an unusual amount of hosts simultaneously? Can you tell me more about your hardware?

We released an update a couple days ago, can you try doing a clean install with that version and see if it solves it?

Glasswire is in “ask to connect” mode (as this is what I need and want).

There are no other services running, except a browser. I’m using a t460s with 20GB ram and 1TB ssd.

I did a clean install, same issue.

I use this mode also with no high CPU problems. If you go to “Click to block” does it make any difference?

If you do a “clean” install of our latest version does it help? After uninstalling GlassWire go to the “Windows Firewall” control panel and click “restore defaults” then try doing a clean install if you don’t mind.

What type of hardware do you use?


It doesn’t make a difference what setting I use.

The clean install didn’t help. I already replied on the hardware question :wink:

I am guessing you double checked the Task Manager and you’re sure it’s GlassWire causing this high CPU usage? Is there anything else unusual about your network or the software on your PC?

Sorry I missed the hardware question.

I will ask our dev team if they have some ideas.

Yeah, I’m a dev myself and “should know” where to look :slight_smile:


If you go to the top left GlassWire menu and choose “About” what version does it show?

It’s version 1.2.88 (writing something so the board lets me post)

Wait this is confusing. I downloaded the latest today and uninstalled and installed. I’m going to do the same again so I’m updated to 1.2.96.

Not overly helpful but it sounds like cpu thrashing. Any chance glasswire or firewall are mid-privileged?
I know it makes no sense but I am as well a dev and I’ve seen this issue in ms office. Where an extension runs code with the wrong permissions.

Mid should be mis
Stupid autocorrect

@lostinlodos You have this problem also, or are you just commenting on his problem?

We haven’t seen other reports so I wanted to be sure it isn’t a problem lots of people are experiencing.

I was commenting I’ve seen it in other software.
Was suggesting the op verify their settings in the os. Sorry if I was not clear.


Thanks for your feedback and idea! Sorry if I sounded rude, I was just worried that maybe other people were experiencing this.

1.2.96 seems to have solved the issue. Though, at the same time, I tweaked the WiFi settings…

I’m glad it’s working! How was the WiFi changed? Anything unusual with it?

Changed some driver parameters like “HT mode” (from VHT mode), on batter still have the setting “maximum performance” and some other one I forgot.

Wonderful; glad it all worked out.