Data usage delay on graph

Hi, I just installed glasswire today and I’m having an issue where the graph isn’t showing data in real time. It’s like for every 6 seconds, it logs 5 seconds worth of data, which causes the delay to get longer and longer. I tried uninstalling, rebooting, installing, and then rebooting again and it is still happening.

After restarting my PC, it appears to behave normally for a few minutes, but then the delay starts becoming more and more apparent. My PC has been on for about an hour now, and it is logging the usage data that was happening 10 minutes ago.

The Usage tab also shows the same delay. Incognito and firewall are off.

I can’t find much information about this, so I’m not sure if this is expected behavior or not. Please let me know if I need to provide any log files or anything


No, this is not an issue I have heard of anyone having before. Are your sliders both slide to the far right? It looks like so in the image.

If you move the left side slider over further while in “3 hours” it will make the graph move faster if that’s what you need.

No, I had the slider over to show where the most recent data was. it was about 3:00pm when I took that image, and the newest data that was showing was from 2:48

I’ll try a gif, maybe that explains it better. It was recorded at about 3:50

It is still loading data, but it’s about 15 minutes behind real time at this point. I’m also noticing that it seems to be loading more slowly than it was before. I’ll try restarting glasswire and see if it’s any quicker


If you go to our top left menu and choose “About”, what version of our app do you have?

Do you use any unusual encryption software or something like that? Perhaps it’s causing a delay for writes to our database?

If you check your SSD with Windows does it look OK and healthy?

I am on version 2.2.268

Nothing comes to mind for encryption software

I ran a quick error checking on my SSD, everything looked fine. However I have had issues with it in the past where it would occasionally hang at 100% use on task manager for around 10 seconds or so, but that’s the only issue i’ve had with it, never any read/write speeds.

Would it be worth reinstalling on an HDD? It’s the only other drive I have and I’ve never had any issues with it


I wonder if our database could be corrupted. If you reinstall our app with the “clean install” option checked, does this issue continue?

If you want to move our database to another drive the instructions are here.