Feature request - give user an alert if product deactivates!


#1

Grrrrrr … not sure how many days this has been going on for, but just opened my glaswire gui (1.2.79( and shocked to find it was off… yes OFF! not doing any blocking of anything… I quickly set it back to “ask to connect” but then it asked to purchase, so I entered my product key again and it activated, and then showing as fine…

PLEASE PLEASE PLEASE if you have a time bomb in the app that deactivates after a certain time period, then its critical that you give some kind of a warning or pop up to the user…

Grrrr


#2

@krevvy

Sorry for the problem. Do you use any third party “PC Cleaning” or “PC Speed Up” type utilities? If so these can delete GlassWire’s files and cause it to deactivate with no warning.


#3

Hi… nope …
Use kaspersky av… but don’t do any cleaning


#4

Do you ever block GlassWire from accessing the network itself?

Can you try uninstalling GlassWire, rebooting, then reinstalling with the “clean” installer option? I think it would make sure this problem doesn’t happen again.

Also some versions of Kaspersky send all your network activity through Kaspersky itself, so if that’s the case it’s possible it could cause a deactivation under some circumstances if GlassWire loses connectivity for a very long time.


#5

Ok thanks. I’ll give it a go


#6

same thing happened to me.


#7

I had same problem with glasswire pro latest version. it is so annoying.


#8

@geek787

This is being redesigned for 2.0 (a free upgrade for you).


#9

good to know that. thank you for letting us know. when can we expect that?


#10

Just wanted to chime in that I have the same problem. Is there a rough timeframe for version 2.0?


#11

Hopefully in July 2.0 will be released.


#12

I have to reactivate every other day. it is so annoying.


#13

@geek787

Please email our “activation” email. https://www.glasswire.com/contact/ Something is wrong with your install or your code is used on multiple devices simultaneously.

If you use CCleaner please white list our directories so GlassWire’s files won’t be deleted.

Please white list the GlassWire folder in the ProgramData folder.


#14

I use glasswire pro and installed on 3 computers.i had sent an email to “activation” email. they had reset the key and asked me uninstall and reinstall. I did so. even then same problem.


#15

Got the same issue. Loses activation from time to time, I also find the most problem since I like the Ask to Connect feature. Gonna try a super clean install eventually and see if it works out.


#16

i am having the same problem . . .


#17

I keep checking each week and have had a few more instances where it’s become deactivated… so annoying (latest instance if the issue last week)


#18

2.0 will be out in two weeks and we changed this.

Meanwhile GlassWire should not become deactivated anyway. Some suggestions:

To avoid this problem in the future go to the top left GlassWire menu and choose “deactivate” before switching your activation code between PCs. If this problem continues please try the following:

  1. Uninstall GlassWire, reboot, then reinstall GlassWire with its “clean” install option in the installer. Unfortunately this will cause you to lose your settings.

  2. If you use PC cleaning software that can delete our files please white list our directories so our registration files won’t be deleted. Please white list the GlassWire folder in the ProgramData folder.

  3. If you use Kaspersky or another security product that sends all traffic through itself please white list GlassWire so it can access the network.

  4. Please unblock GlassWire with its own firewall if possible.

  5. If you have shared your code with others please let us know so we can help you.