For some reason only seeing 1 year history in unlimited version(Elite)

I’m using elite version which should have unlimited history. However, recently I found my history is limited to just 1 year. I’m not sure when this happened, but I can see my history only started at 2017-11-26 (today:2018-11-28), and from time to time the history keeps the 1 year length.(Based on my observation recently).

1 Like


Please go to the top left menu and choose “About” and let me know what version of GlassWire you have.

Elite has unlimited history and we have other customers who have achieved it. Perhaps your software was deactivated to the free version? If so you can re-activate and it will not lose your history.

Tried re-activate, nothing changes.
And maybe have something to do with my situation before? Because I originally bought pro, and after couple months I upgraded to elite.


Perhaps it’s related to starting with Pro, then switching to Elite.

As you can imagine it’s not super easy for us to test this scenario since it takes a year. I guess maybe the team can make a database with pre-filled data maybe to test this idea?

I will report this issue and see if we can recreate it.

I can tell you for sure though that Elite does keep unlimited history and people have done it many times and sent us screenshots.

Let me see if I can find a solution. Please give me some time, thanks.

Thank you for the fast response! As you can see screen clip from my first post:

That I’ve used Glasswire since April 2017, and really attracted by such wonderful functions. Hope you guys can solve this problem. Thank you!

1 Like

Wouldn’t it be easier to take an existing database and change the system time to a year later? Or does GlassWire do a timecheck somewhere else?


I’m not sure, but I will find out.

I don’t know when I started with free GW on three of my systems, but it was early on. I upgraded to Basic in August 2016, Pro in April 2017 and Elite in April 2018.

On my Win 10 Pro test system and Win7 laptop, neither have received any storage upgrades. So those have seen a seemless Free > Elite upgrade path.

My Win 7 desktop HDD was upgraded to an SSD in May 2017 with a clean install of the OS and all apps, so it saw a new install of Pro and later an upgrade to Elite.

Here’s a screenshot from the desktop. All three have identical December 6 2017 thru 2018 timelines. That said, this is the first time I’ve ever examined Unlimited this closely and use the others occasionally with the 5 Minutes and 3 Hours having the greatest benefit. This Unlimited behavior isn’t a deal breaker, but perplexing nonetheless…


Thank you for the sharing!
This kind of bugs are not easy to notice since we usually don’t inspect history at this level. The reason I found this is that I tried to find out how much data I used for last couple months compared to same period of last year. And I found there is almost nothing left for last year.

We found this bug was due to someone starting with Basic or Pro, then upgrading to Elite. The database limit is put on Basic/Pro. We are investigating a solution and I apologize for the problem.


Thank you for the investigation! Looking forward to the solution.


Hello everyone!

We found this is a bug and we are actively working to fix it. Thanks for your detailed reports and I apologize for the issue.


I have observed this same issue with history seemingly disappearing from the Unlimited view, since fall 2018. In summer 2018, I could see history back to September 2017 (the date I deleted my database due to suspected corruption). Throughout December 2018, I could still see history only back to December 2017. Since 2019 has begun, my history start point is sometime in January 2018. Incidentally, my Glasswire upgrade path was similar to that reported above as well (Basic-Pro-Elite) beginning in 12/2016. Additionally, Alerts seem to be dropping off the History view as well. For example, as of today (01/03/2019), I can see Alert history only back to October 2018 even though I can see Hosts and App data back to January 2018. On the Unlimited Graph pictured here, if I set the cursor at a point in early January 2018, then click the App icon, select an app from the resulting small dialog and then choose Alerts in the top line of that resulting dialog, I can see alerts for the app from only between October 2018 through today’s date. I can see no earlier alerts.
Thank you.

Can you report any progress on the fix? Thanks.

We plan to have an update out next week.

1 Like

Excellent! Thank you.

This issue is not fixed yet in the latest update, it’s a bit complex so we’re still working on it.