GlassWire 2.0.115 Service Can't Start On Windows 8.1


#1

So after looking around, I think this may be more of a Windows issue, but I don’t know where else to look; since the program giving me the issues is GlassWire, why not ask here? So, what’s happening on my end is that when I start GlassWire, it gives me that irritating “service stopped running” error, I’ve experienced this on Windows 10 in the past and all I had to do was force close it and reopen it for it to work. That’s not the case this time. No matter what I do, GlassWire will not work. After looking at a suggestion I found online, I opened services.msc only to be greeted by a 1068 whenever I tried to start the service.


I’ve gone into regedit myself to try to fix it using a suggestion from someone on the Microsoft forums, but to no avail. What they suggested is going to HKEY_LOCAL_MACHINE > SYSTEM > CurrentControlSet > Services > Dhcp and deleting everything EXCEPT for “Afd” in the DependOnService value. Nothing else was there, so I thought it was fine. They then said to go to EapHost located in the same general area as Dhcp; and delete everything in the DependOnService value. Nothing was there to delete. My AV software is Malwarebytes and Adaware Antivirus (though that one is stuck in an update loop for some reason.) and I mostly use this PC for gaming, which funnily enough is why I need GlassWire.

If you need logs, I don’t quite know where to find them so I’d need help with that too


#2

@RavenChan

If you uninstall GlassWire in add/remove programs, reboot, then reinstall using our “clean” install option in our installer, does it start to work again? Or does it have the same error?

If you run Windows update does it help?