GlassWire 2.0 issue - all data and configuration is lost


#1

Upgraded to new version, was using data in custom location but, backed it up.
After starting 2.0 - glasswire.db is emptied (300kb) while glasswire.db.20171215033731.backup contains 37mb.
Also lost all configuration (firewall is disabled, etc)
seems it’s using custom location correctly but it starts db and configuration from scratch.

I wanted to redownload previous version 1.2.121 to see if db file was corrupted or it’s a problem with 2.0 installation, could you provide download link to previous version?


#2

@SHADOW13

I apologize for the problem.

I recommend trying these things if possible https://forum.glasswire.com/t/upgrading-to-glasswire-2-0-tips-tricks-bug-reports-feedback-and-fixes

I’ll see if we can find a way to host 1.0 somewhere again.


#3

I managed to find 1.2.121 installation.
Reinstalled it and restored the “service” folder (db/configuration) and it is working fine.

The custom location does not matter (tried with default on 2.0 and still had the problem)
That means there’s something wrong with 2.0 being unable to read my current DB data/app configuration.

Considering it’s nearly year worth of data that would be nice to keep, I will stay with 1.2.121 - maybe future updates will fix it


#4

@Ken_GlassWire - just checked 2.0.84 and the issue still persists.

As soon as I start the service, the existing glasswire,db is moved to a “backup” file and starts from scratch.
All the app settings and historic data is gone.

Works fine on 1.2.121


#5

@SHADOW13

Here is how to backup your GlassWire database, but it seems you may already know how to do that.
https://www.glasswire.com/userguide/#Backup_Settings

Is your Database on a secondary hard drive, or moved to another location, or is there anything else unusual about your setup?


#6

I have a backup, and it’s fine - I installed 1.2.121 and it works fine.
The problem is that the 2.0.xx doesn’t load the existing data


#7

@SHADOW13

Perhaps I got you mixed up with another person, if so I’m sorry.

To move your GlassWire 1.0 database to 2.0 you have to do these things:

  1. First, just to be safe be sure your 1.0 database is backed up.

  2. Install our latest GlassWire 2.0 version on top of 1.0 without moving your 1.0 database. Of course you should keep your backed up database somewhere separate.

GlassWire 2.0 converts your 1.0 database to 2.0. Did that not work at all? If that’s what you said already in this thread then perhaps I misunderstood.


#8

it does not work - 2.0 deletes content of the glasswire.db file (backs it up but does not use the old file)


#9

@SHADOW13

Our team asked if you could try this? Of course back up your database first.

Install 2.0.84 over the existing 1.x version and send us the install logs. You should start the installation and show installation details. Wait until you see the “Starting service” message and copy the log via the context menu.

image

You can then post them here or email them to us. https://www.glasswire.com/contact/


#10

the installation does not star the service because I stopped it before installation, this is the update process:

  • close glasswire app
  • stop glasswire service
  • backup “service” folder
  • install 2.0.84
  • (optional, does not matter, same result) restore “service” folder
  • start glasswire service

after the last part, before starting the glasswire app, just by starting the glasswire service, it backups up existing glasswire.db (40MB) to backup file and new glasswire.db is created with 100-300KB.

new version does not read existing glasswire DB, if I start glasswire app, all the data and all the settings I had are gone

the same process, only with previous installation, “install 1.2.121”, works just fine


#11

Unfortunately, but the backup does not help in restoring. I reinstalled Windows 10 x64 1803, installed the program and activated it, pasted the backup files into the appropriate folders and the program does not work. The error shows me:

Nazwa aplikacji powodującej błąd: GWCtlSrv.exe, wersja: 2.0.123.0, sygnatura czasowa: 0x5b2a0eb9
Nazwa modułu powodującego błąd: ucrtbase.dll, wersja: 10.0.17134.254, sygnatura czasowa: 0x92f5b34a
Kod wyjątku: 0xc0000409
Przesunięcie błędu: 0x000a24fb
Identyfikator procesu powodującego błąd: 0xd488
Godzina uruchomienia aplikacji powodującej błąd: 0x01d44ac06b2079c9
Ścieżka aplikacji powodującej błąd: C:\Program Files (x86)\GlassWire\GWCtlSrv.exe
Ścieżka modułu powodującego błąd: C:\Windows\System32\ucrtbase.dll
Identyfikator raportu: 20cc5813-c3b5-4274-b55a-1afc14ec9540
Pełna nazwa pakietu powodującego błąd:
Identyfikator aplikacji względem pakietu powodującego błąd:

The service after running all the time turns off by this error, so the program does not work.


#12

If you uninstall in add/remove programs, then reboot, then reinstall using our “clean” install option does that solve it?


#13

No, I reinstalled system.