Glasswire (activate / focus application issue?)

Frequently and persistently Glasswire does not respond to right click or left click when I try to click activate it on the system tray this happens very frequently and uninstalling and re-installing has not helped fix it. Restarting Glasswire fixes the issue and lets me use the tray icon again. This issue has existed for a long time and I had hoped that your updates would remedy it but not so.

Thank you.


I just noticed my version is out of date so right now I am going to update from my current version 1.1.31b to Version 1.1.32 beta please let me know if this newer version is supposed to address the issue and I will post if it does not. Going to remove previous version completely and install the latest beta.

Thank you!


I have never experienced this problem myself or seen anyone report it before. If the problem continues after the upgrade please let me know and we’ll try to figure out what’s happening. Please let us know:

  1. Your operating system version.
  2. Do you use any third party software that changes your taskbar/Start menu some way?

Thanks for reporting this.

Thank you Ken I will keep you posted I have just reinstalled and activated.I do run a number of tray and startmenu related programs such as “Classic Start Menu” and I run “Actual Window Manager” I have tried disabling AWM and that has not helped but if the issue persists I will try disabling the Start Menu program also since you mention the start menu too.

I am running Windows 7 64-Bit.

Thank you again!


So far so good but since this is an intermittent issue it may take a while to see if the new version fixed it.

Thanks again.


The issue persists. Clicking the tray icon no longer works again and I tested disabling EMSI Soft AntiMalware, Classic Start Menu and Actual Window Manager they don’t seem to be causing the issue. Interestingly though click the icon will not open the interface nor allow right click menu to appear if a prompt for a new alert appears and one clicks on that the interface opens up.

Thanks. I’ll report this and we’ll try to recreate this problem and fix it.

Thank you Ken.

A temporary work around is to have the mini monitor on. This allows me to click on the mini monitor and this will open the application though clicking the tray icon has no effect.

We think we found this problem and our next update should fix it. Without your report we never would have known about this issue, thank you!

Excellent! Thank you Ken I appreciate your attention to this and I am happy if I helped bring attention to the issue! I look forward to there hopefully being a fix in ther next version. Have a great weekend.


1 Like