GlassWire and NordVPN


#1

Hello, New Glasswire user here and have discovered that Glasswire was blocking Nordvpn.

I found the thread that discusses this issue and offers solution of creating a new line in the glasswire.conf file. But I just have a question or 2.

Here’s a screenshot of my conf file.

The solution is to,
“Inside the GlassWire.conf text file created by Notepad please insert this text.
hostname_enable_nslookup = false”

Does it matter where I insert the line, or should I just change the “true” at the end of existing line 2 to “false”?

Thanks, Larry


#2

@bornconfuzd

You can add the line after the “enable_network…” line, below it.

Thanks!


#3

Fixed, thanks Ken.

Larry


#4

Actually this only worked the first time. After reboot same “no internet” problem. Upon inspection the .conf file had been cleaned of the inserted line leaving it just like my screenshot above.

Then I tried creating a new .conf file using ONLY the “hostname_enable_nslookup = false” line, (without quote marks), and after reboot the conf file has been rewritten again, and again contains only the text in my screenshot above!

What the heck? Am I doing something wrong here?


#5

@bornconfuzd

If you make a new .config file with notepad and put in the same lines as the other one, then drop it into its correct location does it fix it?


#6

No, tried that and next reboot it’s been rewritten/the text I entered is gone. You used the word, “.config” in your last reply and I’ve been giving it the extension of “.conf”, same as the original. Is that the problem?


#7

@bornconfuzd

Please try this:

  1. Stop the GlassWIre service in the task manager. Right click the bottom task bar in Windows and choose “task manager” then click on "services. Scroll to the “G” section and find GlassWire and stop it.

  2. Run SublimeText text editor (or Notepad++) as admin and open the config file: C:\ProgramData\GlassWire\service\glasswire.conf

  3. Set hostname_enable_nslookup=false

  4. Save the file and start the GlassWire service again by right clicking it in the task manager.

We recommend those other text managers because maybe Notepad is not working for you somehow because it is breaking the format.


#8

I was also having the problem that whenever I restarted the service, the glasswire.conf file was rewritten to its original form. I tried editing it in Notepad++, and noticed an immediate difference - instead of one long single line, the text of the file was broken up into seven lines. I tried adding the suggested additional line and saved the file. I noticed that the file was three bytes shorter this way than when I had used Notepad. However, it still got rewritten when I restarted the service.

Then I noticed that Line 5 of the file was “hostname_enable_nslookup=true”. So I simply changed the “true” to “false”, saved the file, and restarted the service. This time the change took. I had to restart NordVPN, but once I did that, everything has been fine.


#9

@zzz

Is it possible you were editing the wrong file? We had another customer with a similar problem, but he solved it by editing the correct file.

If you edit C:\ProgramData\GlassWire\service\glasswire.conf does it work?


#10

No, that’s the file I was using all along.

Everything continues to work fine since my last message.


#11

@zzz

I’m glad it’s working. Thanks for using GlassWire.


#12

I too was having issues connecting to nord VPN until i made this change