Glasswire Basic Unlock Settings not working (Solved)


My Glasswire Unlock settings for all tabs are not working… I have tried to reinstall many times and also set windows firewall to restore defaults and then reinstalled after. Nothing seems to be working. Unlock restores to default state soon after clicking OK.


If you go to the top left GlassWire menu and choose “About” what version are you using?

Are you admin on your PC, or do you have the admin password to the PC?

Version 2.0.91

Admin account - YES


What Windows OS version are you using? Thanks.

Windows 10 v 1709 built: 16299.309

To be frank i have been able to get the unlock working since purchase but i have been using Glasswire free for a long time. but i have clean installed my PC recently and GW still doesn’t work for me


Thanks for your report. We’re unable to recreate this. Is there anything unusual about your OS install at all?

Well, it has 2 accounts one Admin and the other is a work account (also Admin). Not sure how/ if that makes a difference. Is there a log for GW i can submit for you to have a look at? I will try and see if i can make a video for you to have a look at.

Ah, two admin accounts… I don’t think any of us have that. We will make two admin accounts and try to see if that causes the problem.


We were unable to reproduce your problem, but we think there may be a misunderstanding.

If you want to remove the admin rights verification, you should open GlassWire’s settings, click the Unlock button next to “Enable administrator’s account password request” option and uncheck this option, then click OK.

Yup, That sorts it… The locks are gone now and its working as it should. Enable admin account password was the issue.

Thanks Ken. Great help.