Glasswire blocks Linux subsystem for windows 10 (solved)



Any chance that last creator update with ubuntu version 16.04 change this limitation ? I have read that microsoft have changed something to help better WSL Antivirus and Firewall Compatibility

Here MS Notes:



Ooops sorry i just see that @codex22 have already point the Ms article…


I will ask for an update from the dev team, thanks.


This is an older post and the issue is still not resolved where we can work with the Linux subsystem, but I think there is hope they will make changes before it is finalized.


Other firewall manufacturer have at least implemented an workaround

Could this also be a temporarily solution for GlassWire?



I will ask, thanks!


We use this Windows Firewall API, so the fix on that site cannot apply to us unfortunately @caldicot.


That’s a pity… Thanks for your very quick clarification :+1:


Just to be clear… I think when the final version of this software is available from Microsoft it will work with Windows Firewall, or they will have some system in place for us to solve this. At this point it doesn’t make sense to spend a lot of time working on a fix for this since their software is not yet finalized.


Thanks for pointing this out. Hope MS will release final version soon :slight_smile:


Commenting as a vote for this bugfix. Linux subsystem for windows always silently blocked when Glasswire firewall is enabled.


It’s available in the windows app-store now - are you working on a fix?

I’m going to have to remove glasswire from a couple of machines as it’s impossible to even “apt update” whilst the firewall is enabled - at that point it’s time for me to look at another product (disappointing having paid less than a year ago for this one)



Thanks, we will check it out. Is the Linux subsystem made by Microsoft and it’s separate, or is this Ubuntu tool made by Microsoft also?


It’s part of Windows, created by Microsoft to support running Linux binaries on a Windows platform.

More details can be found here:


For completeness, I have “Ask to Connect” enabled, and any tool within the linux shell that requires internet access is unable to connect - however glasswire does not show the requests in the firewall view, nor do I get a pop-up. Dead easy to replicate.


@rob Is the Linux subsystem itself out of beta? I was having trouble finding out from the Microsoft website.


I believe: it’s currently out as part of the “slowest” Windows Insider Edition stream, which means it’ll be made available as part of the mainstream in the near future


BitDefender appear to have solved the problem with their firewall:

Microsoft have a page describing the technical solution to this problem:
(which was posted earlier and you sent to the dev team in December last year)

Do you have a timescale for resolving this issue? I’m reluctant to stop using Glasswire however this is an impediment to getting work done.


Actually, it seems, that the Linux Subsystem will be out of beta soon with the Fall Creators Update:


Is there any update on this @Ken_GlassWire ? It makes the subsystem unusable with Glasswire