Glasswire control service won't stop


#1

I got one of the messages that Glasswire 2.0.105 cannot connect to local server.
I tried to reinstall it but it stopped during deleting the current installation and it tried to stop Glasswire Control Service but it did not work and it hung up.
The service info says “Stopping”
Tried delting it but it is in use by another program.
Windows will not do the uninstall either.
Ron


#2

@Ron

If you install GlassWire over itself again, then go to add/remove programs and uninstall does it solve it? If not, if you reboot then try to uninstall does it solve it?


#3

NO the service still says stopping. Uninstalling does not work because it tries again to stop it running and stalls.
I had previously looked at other posts and tried removing the Glasswire Services directory but it would not as it said file was in use.
Thanks,
Ron


#4

@Ron

Are you able to stop any other services on your PC with the task manager? Or can you just not stop ours?


#5

Yes, I stop Windows Update by opening services and I use Task manager to stop Openoffice Calc when it freezes sometimes.
I had not noticed the services tab on Task Manager. I checked it and it says the same as my approach via services i.e. Glassware Control is stopping.
This all came about as follows. I normally start my computer and it is not connected to the internet. I then open Glasswire and Network sharig centre. I then open WIFI and connect to modem.
But this time (and once before) network started, Glasswire says cannot connect to local server. At that time I rebooted and the problem went away.
This time it would not work, so I tried to reinstall it and got the problem when it stalled trying to remove the previous version and says Glasswire control is stopping but is does not stop!
Ron


#6

Please boot into WIndows Safe Mode, then uninstall GlassWire again.

https://support.microsoft.com/en-us/help/12376/windows-10-start-your-pc-in-safe-mode


#7

Thanks Ken, it did the trick.
I had not used safe mode since an early windows and it was a bit messy to get there using Microsoft instructions. But I got there.
Glasswire still had my last weeks info.
Thanks again, now if only Glasswire could delve into Host processes for Windows service to show whatt programs are using it. I can only see Windows Update by implication.


#8

I’m glad it solved the issue. Sorry for the problem and thanks for your patience.