GlassWire Disconnects Sparodically

My free version of GlassWire disconnects every 2 or 3 days without warning or alert. When I attempt to reconnect, I get the error message “An error occurred. Contact GlassWire for help. Push the “Connect” button to reconnect.” In order to clear the problem, I have to reboot my computer. I leave my computer running 24/7 as I travel quite a bit, and connect to it from distant places. I was on the verge of purchasing GlassWire, but if it is going to be disconnecting from time to time, I am not sure the trouble is worth the price.
In looking through previous requests for help I saw where it was suggested to do a “clean” install. I went one step further and used IOBit’s Uninstaller to make sure I got every bit of GlassWire removed from my computer. Then I did a “clean” install. I will keep you posted on further developments.



I also get this issue, however mine is much more frequent, and sometimes won’t reconnect even after a reboot. I have tried a fresh install, I only started getting the issue after I bought it…

Do you get any dmp files on your desktop? Please try upgrading to our latest version with a “clean” install (as TomR did).


Tried that, cleared everything with revo uninstaller, did a fresh install and after about an hour it just gets stuck “Loading data” forever…

I’ve had similar problems which is why I’m interested to see if your problem is similar.

Do you lose data?

Several users have had a similar problems where the GlassWire service appeared to stop working. This meant there was no recording of data so we had gaps in the graph when we restarted.

So do you lose date or do you have all your data even during the period when GlassWire is not connecting to its service?

Restart GlassWire service instead of reboot?

Some users avoided a reboot by stopping the GlassWire service:

Killing GWCtlSrv.exe from task manager stops the service and allows it to manually be restarted.
Reopening GlassWire then works correctly.

Are your problems similar to others

I wonder whether there are any similarities with what others, including myself, have noticed or speculated:

  • Windows firewall is disabled or replaced by another firewall
  • The problem doesn’t appear to happen when users are working on their computer. But in your case it happened within an hour so you are more likely to have been working on that computer at that time.
  • The problems sometimes appear to be linked to specific activities like:
    • Windows update during the middle of the night
    • Connecting to different networks or connecting using different network adapters such as wireless to cabled.

Hm, yes I see. I have the prior data that it collected, if I switch to the 3 hour view I can see it, but Glasswire has not logged any data since my last post, it’s just been stuck “Loading data”. I was on my PC at the time I noticed it stopped collecting. Killing and restarting the service did not yield any new results, and is still just stuck on “Loading data”. Turning off windows firewall had no apparent affect. I’m on a wired connection, with no wireless capability.

I guess some more information may help:

Windows 10 Pro
10.0.15063 Build 15063

Glasswire Basic 1.2.100
Miniviewer enabled

Webroot SecureAnywhere (Disabling it doesn’t seem to yield any different results)

This is an elusive problem so any more information you could provide might help the GlassWire developers to pin it down.

If you have the time then you might like to look into the Windows event logs.

When did GlassWire stopped logging?

You should be able to determine the time when GlassWire stopped logging.

To get the most precise time I would click along the graph moving right past the point where data collection ended until the upload and download numbers displayed below the graph are both zero.

The sooner you do it then the more accurate the time will be as each graph has a different precision, i.e. a three hour graph will be accurate to the nearest minute but the 24 hour graph only to 5 minutes:

Usage view Time period
5 minutes 1 second
3 hours 1 minute
24 hours 5 minutes
Week 10 minutes
Month 3 hours
Unlimited 24 hours

What Windows events are logged at the same time?

Then check the Windows event logs to see if any events, which might be relevant, are recorded at that same time. For example, I found that Windows was waking my computer in the middle of the night to run windows update and then going back to sleep. Sometimes this has caused a problem with GlassWire and other programs.

If you do this several times then a pattern might become apparent.

How to use Windows Event Viewer

If you haven’t used Windows Event Viewer then there are many useful articles to help, e.g.

GlassWire stopped logging at around 7:45pm

There was an event viewer log that seemed semi-related at 7:21, but it was still logging for a little while after this occured.
The application-specific permission settings do not grant Local Activation permission for the COM Server application[…]
to the user NT AUTHORITY\SYSTEM SID (S-1-5-18) from address LocalHost (Using LRPC) running in the application container Unavailable SID (Unavailable). This security permission can be modified using the Component Services administrative tool.

However turning on my PC this morning I still cannot get it to reconnect, I’m sure I’ll have to do another reinstall

The APPID or CLSID reported with the event can be used to search the Windows registry to see what program it is.

That sort of permissions error does happen with incomplete installs and can have a symptom of recurring problems not fixed by reinstalling the application. But I’d be surprised if it is related to GlassWire.

We had another customer with this problem and we found their security software was killing our process. Is it possible that could be the case here? Is there any unusual security software installed that could be killing processes, drivers, etc…?

Yeah, I considered Webroot may be doing so, but I’ve tried disabling Webroot as well, only after glasswire stops logging. I suppose its possible that the monitoring process was killed in an unusual way and couldn’t properly recover… I’ll give it a go disabling webroot before boot.

Do you happen to remember what software the other client was using?

Well, completely disabled anti-virus and still couldn’t get GlassWire to connect. Where can I download the beta version?

The software was proprietary if I remember correctly.

How much memory does your PC have? Do you run Bittorrent often? Are you sure there are no dmp files on your desktop?

We have no beta version, but our latest desktop software is available at Sorry for any confusion.

I’ve installing Webroot SecureAnywhere trial version - I regularly change antivirus so it’s no problem to do so - so I might be able to see if it is causing the problem. This sort of problem happens very few people so I may have no success reproducing it.

Did you have the GlassWire problem before you updated to this version of Windows? If so, then I could test on my Windows Pro computer which is on Version 10.0.14393 (1607).

In the meantime, I’ll try the Webroot SecureAnywhere trial on Windows Home Version 10.0.15063.

I don’t torrent anything, I have 32gb of ram, and I’m certain I don’t have any dmp files on my desktop.

I’m not sure, I did have GlassWireinstalled before updating, but I didn’t use it much until I bought it for the mini display. However I didn’t ever notice it when I first started using GlassWire.

Webroot SecureAnywhere (WSA) can interact with the Windows Firewall and can terminate the GlassWire processes so it will be interesting to see if any problems develop for me.

  • WSA front ends the Windows Firewall so it is a potential conflict with GlassWire. WSA says that it handles outbound connections which is what GlassWire also does.
    So far, WSA’s pop-up windows for 'Warn if any process connects to the Internet unless specifically allowedappears GlassWire'sAsk To Connect` notification.
    • WSA | PC Security | Firewall
    • WSA | Advanced Settings | Firewall / Web Shield
  • WSA can control running processes including GlassWire’s processes.
    • WSA | Utilities | System Control | Control Active Processes`

Hm, interesting, I wonder if any of those stay active after shutting it down… Let me know what you find out, I’ll tinker some more with it. Although my active process control looks like this

Good to see there is no GlassWire process being blocked on your system.

I have found no problem with WSA. Nor have I reproduced your problem. I think it is unlikely that I will because, even if WSA is related to the problem, it affects so few people that I may not be able to reproduce it.

As for WSA, it’s working fine. It seems light-handed in interacting with Windows and other applications. My memory of Webroot AV is a little hazy, having not tried it since last decade. But it does appears to be a much better product. Like automatically monitoring software that it is not familiar with, e.g. wscc.exe:

Comparing the firewall feature it with GlassWire, I don’t like that the WSA firewall setting didn’t appear to show any change in the Windows Firewall. I much prefer that any changes made using GlassWire’s Firewall tab show up in the Windows Firewall rules and settings; I can immediately see whether features are working correctly.

Yeah, I really like Webroot, for the most part it behaves smart and intuitively. I also like how light it is in it’s resource use. I guess my next step, I’ll try to boot into safe mode and run Glasswire from there.

1 Like