Glasswire is triggering off Windows 10 Defender (solved)

I’m testing it now with windows 10 pro

@Ken_GlassWire Even after a clean install, I got this report today :
image

What should I do…?

@Indigo

Thanks, I will report this. I have not seen anyone else report this since the update, but if it happens to anyone else I hope they will chime in here.

Were you in “Ask to connect” mode or “Click to block”? Did you restore the firewall defaults and choose the firewall reset options with GlassWire?

Just a clean install won’t reset the firewall, so perhaps it’s still left over from a previous version? Sorry about not being more clear before.

My windowss is totally new install from when I was using this with issues with defender. mine is truly a new install-OS. I’m not even going to say its fixed or not until a week passes.

1 Like

I’ve been on my PC all day with numerous unrelated restarts and not a peep out of defender and Glasswire yet.
It’s looking good so far.

@Ken_GlassWire I’m on a Windows 10 machine. Firewall is set to “Ask to connect”.

When doing a clean insteall, I indeed restored the firewall defaults (I checked all the possible options in the installer).

1 Like

@Ken_GlassWire I’m sorry but this is really getting out of hand, I have Windows Defender triggering multiple times a day now:
image

Do you have any information?

Thanks.
Regards

I can assure everyone that this new version does not trigger Defender. It’s been several days now with no issues. I had a new install of windows pro 10 and one install of the newest Glasswire.

If people are having issues even when installing they click the check box “clean install” and “reset firewall” then there must be something lingering behind from an old installment. Possibly registry issue.

1 Like

@JHefile

I’m glad to hear it’s fixed!

Ok. I did an install with the option “clean install” and “reset firewall”, but I could still see some Glasswire rules in the Windows firewall listing. So I did remove any specific rule by doing “Restore default policy”.

All seems to have been reset in Glasswire. So it’s really a clean start.

I’ll see if the issue arise again :slight_smile:

1 Like

Still fixed here.
I think part of their attempt to fix this was to not let you block ‘Microsoft Malware protection’ and ‘Antimalware Service Executable’ via firewall.

I am hesitant to say this is the total reason it is fixed. I recall other versions causing a false positive even when not blocking anything.

Either way it’s fixed now and I cannot block those two listing. I don’t want to block them so I am good to go.

1 Like

Just to confirm that it is fixed indeed. No more alert in more than 10 days.

Thanks for your support!

1 Like

Hi,

The same issue is happening again with the latest versions of Windows and Glasswire. Please let me know if there is a way to export the firewall rules, otherwise, I cannot simply uninstall the Glasswire because of many rules that I’ve created in it.
Microsoft Windows [Version 10.0.18362.145]
GlassWire 2.1.152

Our QA always tests for any Windows Defender issues before launching new versions. Also, our entire team uses Windows Defender and we haven’t been able to recreate this. GlassWire did have an issue with this in 2018, but we made changes so it shouldn’t happen again.

We’ll check and see if we can recreate the issue. If anyone else is having this issue please reply to this thread also with details of your Windows version also, thanks.

I have shared this with our team and they may have more questions.

I also see you are not using our latest GlassWire version. Our latest version is 2.1.157.

Thanks for your quick reply. I’m upgrading to the latest version. I’ll keep you posted if I face the issue again.

1 Like

I always have at least one PC using the Windows 10 default AV with GlassWire and I have never had any of the false-positive problems reported in this forum. I wonder why: can you tell from the rule if it is created by GlassWire or the user?

I was once able to recreate this with a very old version of GlassWire before we made some changes to make sure this would not happen again. So far I haven’t seen any other reports about this with our latest software so I’m hoping this was just an anomaly…

Our QA is currently investigating the issue carefully with different Windows versions to try to recreate the issue.

One way this issue could re-appear is if the user used the older version we had (that did have this issue). In this case the old firewall rules could theoretically still exist and they could cause this issue to re-occur even with our latest software. If that’s the case, the solution would be to uninstall GlassWire in add/remove programs, then go to the “Windows Firewall” window and choose “restore defaults”. Then reboot the PC - an important step.

Now reinstall our latest software using the “clean install” and “reset firewall” options where they are both checked. The issue should not be able to re-occur once you take these steps. @Adel

I was able to recreate this false positive from Windows Defender. We are working on implementing some new changes, then we’ll release an update.

It seems Microsoft changed something lately so we now have to make some more changes ourselves too.

If you are in “Ask to connect” mode, or if you block the “Antimalware Service Executable” then do a Windows Defender scan, you will see this false positive. You can then “Allow” it, and you should have no problems while we work on releasing an update with a change to solve this.

Everyone, please upgrade to our latest GlassWire software. This issue is now solved.
https://www.glasswire.com/download/

Version 2.1.158 - (June 13, 2019)

Hash # 560465EED8F83CE983A9C4E5261E6B5C54BA4C824E44B0E46032FE24E480FA50

  • Fixed a bug that could cause a Windows Defender false positive Trojan:Win32/BlockMsav.A!reg. If you are experiencing this issue please be sure you’re using our latest software.
  • Fixed some incorrect French language translations.

If you continue to have this issue uninstall GlassWire in add/remove programs, then go to your Windows Firewall control panel and choose “restore defaults”. Now reboot - IMPORTANT!

Next reinstall our software with the “clean install” and “reset firewall” options checked. The issue should not happen again.

1 Like