Glasswire not showing remote PC usage

Hello,
I have a GlassWire Elite subscription. I had GlassWire installed on 3 PCs and everything was working properly. Today I had to reinstall Windows on one of the PCs. After reinstalling Windows 10 and GlassWire and adding the 2 remote PCs. GlassWire no longer shows the data usage of those 2 remote PCs. It connects and shows everything else but not the data usage. I tried uninstalling and reinstalling GlassWire on my PC and the other 2 remote PCs but this didn’t solve the problem. I even tried clean installing GlassWire and losing all my data history and still this didn’t solve the problem.

What can I do now? paying for the Elite subscription and not being able to use a feature that is available in the free app is frustrating to say the least.

@yassin

Sorry for the issue. If you go to the top left menu and choose “About” in all GlassWire installations, is it all different versions, or the same version?

If you upgrade to our latest version everywhere does it solve it?

Same version 2.3.335 on the 3 PCs

Could you post a screenshot of what GlassWire shows? The reason I ask is because we haven’t seen this happen before, so I am not sure what’s happening.

Please email if it’s private, or just send it to me privately in the forum.
https://www.glasswire.com/contact/

@yassin

And if you look at the remote PC (on the actual PC itself) everything looks normal there, or is it blank there too?

Looking on the remote PC from the PC itself shows everything correctly.

Is there a live chat or something that we can use to solve this issue? it is critical.

@yassin

I apologize for the issue.

Our team has not seen this issue before so I have to escalate the issue to get some suggestions. At this time, if it’s critical I’d recommend the following:

  1. Go to add/remove programs on all machines and uninstall GlassWire.

  2. Reinstall our latest version with “clean install” checked.

  3. Set up everything again. Be sure nothing related to GlassWire is blocked on GlassWire’s firewall.

I know you already did a clean reinstall, but I’d appreciate it if you’d try one more time on all three machines if you’d consider it. Meanwhile I’ll ask our team what else they can suggest.

Do you use any unusual security apps on these machines that could be conflicting with GlassWire somehow? If so, could you try to disable them temporarily to rule that out if it’s safe to do so?

I tried many things. The issue got fixed after I made sure that all PCs are in the same timezone. I’m not sure what’s the relation between the timezone and GlassWire showing usage data.

Anyway, Since I had to install and uninstall and reactivate GlassWire several times today. Is there any way to know how many activations still available in my subscription? I want to make sure not to waste the number of PCs available in my subscription.

2 Likes

@yassin

Thank you very much for finding this bug! We will get to work on fixing it immediately.

I apologize for the downtime you had.

You shouldn’t have any subscription issues. Our system is designed to avoid these issues, however if you did somehow find an issue just email us the code and we’ll quickly help you.
https://www.glasswire.com/contact/

You may see issues about activation codes posted in the forum but these are posts about our old original codes that work a different way.