GlassWire not starting v1.2.74

GlassWire doesn’t start sometimes when I restart my computer. The icon is grayed out.

  • It doesn’t work if I Exit and restart GlassWire.

  • It doesn’t work if I run GlassWire and try to reconnect

  • It does work if I run GlassWire, wait for the reconnection to fail, restart GlassWire and then reconnect.

I’m running GlassWire 1.2.74 on Windows 10 1607 64-bit.

Windows event viewer shows:

A timeout was reached (30000 milliseconds) while waiting for the GlassWire service to connect.

and:

The GlassWire service failed to start due to the following error:
The service did not respond to the start or control request in a timely fashion.

I upgraded to v1.2.76 and the same thing has happened again.

The only difference that I can think of is that each time I had installed a device driver which needed a Windows restart. But it doesn’t happen most of the times I install/update a device driver. I’m updating a lot of drivers because this was a clean install of WIndows 10 AU.

1 Like

@Remah

Did you get any dmp files on the desktop? Do you use any third party security software that could be blocking our service from starting?

No dmp files.

Default Windows Defender security.

In the end it happened one third of the time I installed new device drivers and restarted Windows.