glasswire notification not giving me the option to block or allow

Hi, as the title says, when I get a notification of first network use, there are no options to allow or block the access.
Yes, I can go into glasswire logs or Firewall and block it there, but if it’s malware that I’ve been unfortunate enough to pick up then it’s too late - it’s already accessed the internet and maybe downloaded a root kit or a Trojan, or whatever!

I wanted an alternative to ZoneAlarm as it causes problems, but this is NOT secure, so, if I’m not missing something in the settings, I won’t be buying it, unfortunately. :frowning:

Please go to the firewall tab, then turn on the GlassWire firewall, then under the button choose the pull-down menu and choose “ask to connect” mode.

Sorry, yes, before my post was approved I discovered that I hadn’t turned on the firewall - duh :roll_eyes:
Thanks, it’s working now.

Although, the option to allow this time only would be really good :slight_smile: :smiley: