Glasswire service stopped working (version 2)

Hi,

Today I did a fresh (clean) installation of version 2.
OS = Windows 8.1 (64 bit)

But I see this error “Glasswire service stopped working”
clicked “Restart GlassWire”. No use. same error
Then went to services.msc and tried to start the “GlassWire Control Service”. Got an error message. (screenshot enclosed)

Then Uninstalled Glasswire. No GlassWire folder found in “Porgram files (x86)” and re-started the OS
Then did fresh re-installation of Glasswire v2
Same problem and same error

@Rafale

Do you use a third party unistaller to uninstall GlassWIre? If so please try again, but just use add/remove programs. Using third party uninstallers can miss our driver and cause this problem.

If that’s not your issue, can you try a clean install one more time as mentioned here (don’t forget the reboot!). https://forum.glasswire.com/t/upgrading-to-glasswire-2-0-tips-tricks-bug-reports-feedback-and-fixes

Did you get a .dmp file on your desktop?

First two times I used third party uninstallers
Third time I installed and got the same issue. And uninstalled third time via. add/remove programs.
Then re-started OS and re-installed GlassWire. Still same issue. I’ve given-up and don’t want to try this software again for sometime.
There is no .dmp file in my desktop

I hope the day will come when glasswire team will stop telling users to do uninstall-restart-reinstall
But still a good software if it works

Sorry, third party installers don’t remove our driver and they cause this problem somehow. We’ll continue to try to find a solution.

Hello, I have this exact issue. I’ve used the add/remove programs and I have done a clean install.

@Lynk

Please right click your Windows Taskbar, then choose the Task Manager, then go to your services and find the GlassWire service and try restarting it. Will it start?

No it says ‘start’ service when I do I says Access denied.

@Lynk

Are you using any third party software that blocks apps from running? For example a white list system?

Yes I have Voodoo Shield but had it disabled it when installing and running GW. My anti-malware hasn’t blocked anything. Before 2.0 everything worked great with the same set-up.

@Lynk

Maybe they had us white listed before, and now with the update they didn’t know to do so? I’m not very familiar with the product.

Is there a way to specifically white list our driver, or anything we sign with our certificate?

No, it allows the program to run that’s installed can run and if it blocks anything then a pop message appears letting you know. it hasn’t blocked any drivers.

@Lynk

We will have a GlassWire update out tomorrow. Please try it and let me know your results.

You’ll see when it’s available by monitoring this page https://www.glasswire.com/changes/

Yeah a free user. Yes anything in red is blocked and usually comes with a pop up but Glasswire hasn’t been blocked. Even with it disabled when Glasswire was installing.

Also I have tried the new update Version 2.0.80 and still have the same issue. Connecting to local server 1, 2 ,3 attempts and fails also Glasswire service stopped running.

Please try the update that came out this morning: https://www.glasswire.com/download/

Nope no dice. Still the same issue. Connecting to local server 1, 2 ,3 attempts and fails also Glasswire service stopped running.

1 Like