Glasswire Settings (do not stay as configured)

Hello, I’m new on this forum.
Can anyone help me with the following issue?

When I go to Settings > Security // Data Plan // VirusTotal and I use the unlock button every option I selected turns green. Then I click the OK button.

But when I go back to the Settings and check these options
all the buttons are back in the UNLOCK state and all is greyed out!!

My OS: Windows 10 Pro

Thank you for your advice, help & support

1 Like

Is this a new install of Glasswire?
Which version of GlassWire?
Do you also have a problem saving firewall changes? Or are you using it for free?

I remember someone else having a similar problem with the settings. The problem was resolved but I can’t find the topic/post when I searched for it. It’s not this firewall topic which was also resolved. But that firewall problem affected several users and I can’t see any other users reporting your problem so it may not be a bug.

Do you run any security software that might prevent application software changes?

Have you tried:

  • Restarting Windows?
  • Reinstalling GlassWire?


First of all the VirusTotal feature is free for all GlassWire users free or paid so everyone should be able to use it.

If you change this setting where it is unchecked and press “OK” does it solve it? Go to the top left GlassWire menu and choose “settings”.

FYI, Rudi is also saying that this problem also occurs in the Security and Data Plan settings.

1 Like


Oops, I missed that.

Hi @Remah, @Ken_Glasswire,

It is a new installation of Glasswire (2.1.167 as registered user with license on 18/01/2020)
OS : Win10 Pro (EN)

Unlock [Enable admin account password…] does also NOT stay checked after pressing [OK].
Changing the clear history option from ‘All’ to ‘Keep last week’ has NO effect.
It stays on ‘All’.

I am using Super-Anti Spyware’ + ‘Windows Firewall Control (Malwarebyte) as protection software on my system. Windows Defender is disabled on my system.
I have no problems to configure other software using this ‘Windows Firewall Control’ software.

Hopefully someone can figure this out and solve this problem.

Thank you for your info.
Rudi (Belgium)

Have you restarted Windows after the install? That is worth doing.

I just did:

  1. re-installation of Glasswire 2.1.67 (as admin)
  2. did not start up the program
  3. rebooted my PC immediately

Then I started the program (as admin) and tried to adjust the settings which gives me troubles.
The result is identical as before! No settings I change are kept after clicking OK.

I can NOT unlock [Security], [Data Plan], [VirusTotal] and change the [Clear History] state.
When I reopen the settings the ‘Unlock’ buttons are in the ‘Unlock’ state again.

I am a bit disappointed that this isn’t working for me.
Hope you can find me a solution.

Rudi (BE) :belgium:

1 Like


Perhaps our settings are corrupted somehow. Please uninstall GlassWire in add/remove programs, reboot, then reinstall using our “clean install” option and see if that solves it.

1 Like

I have same results. Setting does not remain.

1 Like

We will try to recreate this on our end. Meanwhile we’ll have a major update out soon that’s redesigned, so this issue should not exist anymore.

Thank you for your effort.
Hope to see develop Glasswire even more.

1 Like