Glasswire stopped working

Glasswire stopped working, It was no longer logging the activity.
I uninstalled it and reinstalled using the latest updated progam.
Unfortunately it won’t even install. It comes up with installation failed, followed
by a flow of exe and dll it cannot execute.
This is an awesome program and I really want to be able to use it again.
Any ideas how I can get it to reinstall and work again?


Are you using a third party security software of some type that could be blocking our installation? If you launch GlassWire again and choose the “clean install” option it won’t follow through at all?

May I ask what OS version you’re using and what language it’s set to?

Hello Ken
I am using Norton Security on Windows 10, english.
I initially installed Glasswire to find the program that was using all my data, it was my previous
antivirus McAfee.
I uninstalled the parts of glasswire that did install last time I tried.
I tried again to install yet same issues. I also disabled my antivirus/firewall.
I still get the same issue. The first notification says…
Error opening file for writing c:/Program Files (x86)\GlassWire\GWCtlSrv.exe

I am using the latest version of the glasswire installation software to install.


@Andrew_Milner is GlassWire working now though? I want to be sure I understand. If you reboot and choose our “clean” option GlassWire installs, but with the default option it fails every time?

1 Like

Hey Ken.
The installer didn’t give me the option between clean or default.
However I tried installing again after rebooting my computer and redownloading the Glasswire installer. It managed to install without issue this time. I am still unsure why it didn’t work, but it worked this time, the program seems to be logging usage correctly as well. Before it froze on me.
Thank you for your help Ken. It is much appreciated.

1 Like