Glasswire Things empty

Glasswire: 2.2.241
Win 10
Just installed the update and Things tab is empty. When I click scan it goes to the 3 dots real quick and back and still nothing.

1 Like

@Anjoland

Are you on Ethernet or WiFi? Did our previous version of GlassWire work for you, or are you new to GlassWire?

Ethernet, no not new. About 4 years. Also realized its not working on a Win 8.1, machine, ethernet. Previous version, 2.2.210, worked fine.

Another person has this issue and they are testing a special version. If you’d like to also test a special version and send us logs please email me with a link to this thread.
https://www.glasswire.com/contact/

@Anjoland

Well I went back to the previous version, Things was empty, but it actually scanned and brought them back. Where as the new version, I click scan and it just ends real quick. Maybe a misplaced period. :slight_smile: Also the graph on the new version seems weird like it doesnt keep up with the right to left scroll and eventually it scrolls pretty much off the screen.

1 Like

Sorry, I don’t understand what that means. Could you post a screenshot?

I’m having the same issue. “Things” Devices are 0. If I hit the scan button, it scans for about half a second and still 0. No devices at all. After new version 2.2.241 install. Worked fine before. Yeah I’ve done the uninstall,reinstall hoop jump. Wlan AutoConfig,Base Filtering Engine and Windows Event Log are all running…IDEAS ??

1 Like

We found a solution and this will be fixed in our next update.

Ken

I have the same problem. Glaswire will not connect to the local server.

The new update will be welcome BUT when will the new update be released. That is very important information.

Having a working firewall is vitally important now days and having a defective update is a major disappointment and very real security risk for your customers, as I am sure you realise.

1 Like

I tried uninstalling the latest update and re-installing the previous version. That did not work and I lost all my firewall settings. It also reverted to the trial version.

Please email me with detailed instructions how to overcome this disaster. In the meantime i will have to try Zonealarm

John

Sorry for the issue.

Why can’t GlassWire connect to its local server and why won’t GlassWire’s graph load?

GlassWire for Windows has a local Windows service that runs locally on your PC. This Windows service keeps track of your network activity for your PC or server. If that Windows service cannot start then GlassWire cannot graph your data usage.

Please note your graph data never leaves your PC, and we at GlassWire cannot ever access that data since it’s only stored locally on your own PC or server. Our privacy policy explains how we can’t ever see your data.

If you are experiencing this problem first try rebooting your PC. If GlassWire still cannot run please uninstall GlassWire in add/remove programs, then reboot your PC (this is an important step in the process), then reinstall GlassWire while checking its “clean install” option in its installer. You can download our latest software from our download page.

If GlassWire’s graph will still not load please check to see if the following Windows services are running in the Windows task manager:

  • WlanSvc (WLan AutoConfig)
  • BFE (Base Filtering Engine)
  • EventLog (Windows Event Log)

These Windows services are usually on by default unless you disabled them. If you find these services are running but GlassWire will still not run please consider running Windows Update. With very old versions of Windows GlassWire may not run properly. After updating your device please once again try a clean install with GlassWire in the order listed above.

@johncranmer

I apologize. Do you still have your order email? If you follow the instructions you can re-activate. Also a clean install would not normally cause GlassWire to go to the trial version.

If you don’t have your order email please message me privately here or email me.
https://www.glasswire.com/contact/

I will personally help you get GlassWire running again.

Hello, when will you fix this problem?
“Glasswire: 2.2.241
Win 10
Just installed the update and Things tab is empty. When I click scan it goes to the 3 dots real quick and back and still nothing.”

@Dredd84

I think it should be out next week. Are you on an Ethernet connection?

1 Like

Yes (Ethernet connection to Wifi Router). I checked with another program (SoftPerfect Wifi Guard), it shows the connected devices.

1 Like

@Dredd84

Yes, that’s the known issue. It’s related to Ethernet. Thanks for your patience.

So has the issue been fixed ? I haven’t updated for over a month because of it. Still running 2.1.167 .I’m not on ethernet, I’m on WiFi…I only have the blank “Things” issue.

@l2829tad

Yes it’s fixed, please update.

I forgot to update this thread.

Version 2.2.258 - (October 6, 2020)

Hash Full # 5E32E4B1C9F2B4FE104DADFB0E662D02E3701968B21076AB5D084B3F8E5392BD
Hash Lite # 084C9D99B35ED847C62538DE34483284E2D28DC06BD37BF07AC35227D68CEC70

Usage data can now be sorted by publisher.
Desktop alerts now include publisher information.
Scroll bar improvements as requested by GlassWire fans.
Fixed an issue with our Polish translation.
Fixed an issue where some ethernet users would have zero “Things” listed.
Fixed a bug that caused DNS change alerts to constantly appear for some users in some unusual situations.
Fixed a problem that can cause the GlassWire tray icon to look blurry.