Glasswire will not allow new app to connect with “ask to connect” and no notification

I have uninstalled and reinstalled. I have rebooted. Have deactivate subscription and reactivate subscription. Can’t seem to get “ask to connect” to work.

As long as “ask to connect” is activated, anything else besides those already in the rules will get blocked and no notification at all when there is new connection. The only way for me to allow new apps to connect is to change to “click to block” mode and then switch back to “ask to connect”

Still then I can’t get “ask to connect” notification to work.

I only have malwarebyte free version installed. So no firewall and no active running anti virus.


Could you try this?

  1. Uninstall GlassWire in add/remove programs.

  2. Go to the Windows Firewall control panel and choose “restore defaults”.

  3. Reboot - IMPORTANT

  4. Reinstall GlassWire with “clean install” and “reset firewall” BOTH checked.

  5. Turn on our firewall, then “Ask to connect” and see if it works.

Tried this still doesn’t work. no pop up. And the app cannot connect to the internet…


Would it be possible to email me with a link to this thread? We can then provide a logging version of GlassWire Monday that will help us find/fix this issue.

We have one other person with this issue also and we need your help if you’ll consider it.

Also having this issue.
After install firewall will block everything.
No popups.

I just wanted to play Guild wars 2 again. Got a popup for the guild wars2.exe but for the second exe (CoherentUI_Host.exe) they use for the in game shop there was no popup at all.
And since I instantly tabbed out after opening the shop to click any appearing popup to allow it I can say for sure there was none.
It wasn’t even listed under alerts or under blocked. Other stuff so far was working ok, gw2 not.
From the windows firewall log maybe it could help:


Local Time: 2020/05/24 17:56:37
ProcessId: 4280
Application: D:\games\gw2\bin64\coherentui_host.exe
Direction: Outbound
SourceAddress: XXXX
SourcePort: 53912
DestPort: 443
Protocol: 6
FilterRTID: 86809
LayerName: %%14611
LayerRTID: 48


Could you please also email us as explained above? It would help us a lot. Thank you.

Its easy,

Fresh install , add activation key , move firewall to on and “ask to connect”.
All traffic from new apps is halted, no popups are created for new apps and for auth.




I personally use “Ask to connect” all the time, and I cannot recreate this. But yes, it’s good it’s so easy to recreate on your PC because it will help us solve it. Thanks for emailing!

I am now waiting to hear back from my team on next steps.

Hey Ken,

I’m also having this issue,
However I can report on my desktop using Glasswire v2.1.167 this issue is not present,

I’m seeing this issue on a new computer I installed using Glasswire v2.2.201
Please let me know how I can send logs as well to help you guys troubleshoot


@NChipper @Francisco_Cardoso @Geri123 @Ray

Please switch logs on, recreate this issue, then send us logs.

  1. Stop the GlassWire service with the task manager under “services”.

  2. Open the file: C:\ProgramData\GlassWire\service\glasswire.conf as administrator.

  3. Set parameter LogEnabled to true and save changes.

  4. Start the GlassWire service.

Please start a few apps that need network access and get no prompt, then send us the logs from C:\ProgramData\GlassWire\service\log as soon as the issue is reproduced.

Please email them to any of the email addresses on this page ASAP.

Please include a link to this forum post so I know what it’s about if possible.

I had that happen once during the beta. It appeared hours later after I stopped playing.

1 Like

For those who had this issue and emailed us the logs, I have replied with a version of GlassWire that should fix this.

Please test it and reply to my email and confirm the fix works for you (or not).
@NChipper @Francisco_Cardoso @Geri123 @Ray

One person has replied so far and says the update fixed the issue. We look forward to hearing from the rest of you that the issue is now fixed.

We’ll then put out a public update. Thanks for your help in finding this problem.

Just submitted my logs. Hope it helps.

1 Like


I replied to you and sent a version that should fix this. Please give it a try and let me know your results. Thanks for sending the logs!

i have no updates … where is it ?


Maybe the email was filtered somehow. I just sent you the file via a private message in the forum itself. Look at the top right in the forum and you should see my message with the Dropbox download link.

Please let me know your results.

Just saw it … installing

1 Like