Glasswire will not allow new app to connect with “ask to connect” and no notification

@Francisco_Cardoso

That’s great! Just respond to my private message if that’s convenient for you. Another person said this custom build solved the issue completely for them. I hope it does the same for you.

Awsome, working now :slight_smile:

1 Like

@Francisco_Cardoso

Great! We will include this fix in our next update that should be out in the next few days. Thank you for alerting us to this problem and helping us find the cause.

@Ken_GlassWire

Working perfectly now. Thank you for the quick solution!!!

1 Like

Hi @Ken_GlassWire and team,

I’m having the same issue after doing a fresh installation of Windows 10 version 2004. Any updates on the public fix/update for this issue?

Thanks!
Naseem

@nastron

Email me and I’ll send you an updated version. It should be out to the public next week.
https://www.glasswire.com/contact/

1 Like

Me too
After fresh w10 installation no more pop ups

1 Like

@Albert1

Success! The new 203 build works great just like it was before! :tada:

Thanks Ken!
Naseem

2 Likes

It solves the problem
Thank you Ken

1 Like

I’m having the exact same problem.

1 Like

@KeithMyers

I’ve been pulling my hairs out for hours trying to figure out why glasswire firewall isnt working on my fresh windows install. Finally found this thread only to find out I’ll have to send an email and wait for a reply for who knows how long.

Its been 19 days since you said “It should be out to the public next week.” At least you could’ve posted an update here saying it’s going to take longer and maybe a beta version link.

1 Like

@glasswirebrokeagain

The update will be out today. I apologize for the issue.

I have been replying to people who email very quickly actually. Also, this problem is related to an unusual Windows setting that most people don’t have.

“Ask to connect” is not broken for most people. Our quality assurance testers would have caught it. Plus I use this setting quite a bit so if it was broken for everyone I would have known immediately.

I believe I have replied to your email also by now, everything is caught up. If you don’t see my email check your spam/bulk folder please.

Thanks for your patience. We are being conservative with the next release to make sure we don’t accidentally introduce another issue.

What is the unusual setting? A few days ago I tried to switch to ‘Ask To Connect’ mode (using v2.2.201), and GlassWire became unresponsive. After going in again afterwards, it wasn’t even possible to click on that dropdown option anymore. And Windows itself then became very confused about whether it even had internet connectivity anymore. Basically, everything internet connection related, and firewall related, became borked. I eventually managed to get GlassWire uninstalled cleanly, had to completely reset my firewall settings to default in Windows, and then do a reinstallation of Glasswire. After getting back on track again, I just left GlassWire’s setting on ‘Click To Block’ for fear of breaking everything again.

I’ve now upgraded to v2.2.210 but I’m not sure whether it’s safe to click ‘Ask To Connect’.

I’m curious to know what was so unusual about my Windows installation that GlassWire 2.2.201 got things completely borked when trying to enable ‘Ask To Connect’.

It was something to do with Windows Event Viewer.

GlassWire 2.2.10 is now available for download, and it solves this issue. Please update if you are experiencing “Ask to connect” problems.