GW 1.2.64b idle monitor crashing (GWIdlMon.exe dumps on desktop)

GlassWire version 1.2.64b idle monitor suddenly started crashing and dumping its log/error data on desktop, on a Windows 10/64 bit PC.

(No Nahimic is not installed, nor has it ever been on this machine!)

Dropbox links to some of the (~66mb) log files sent to

Would really like to know what causes the issue and/or find a possible solution.

@Bernard It seems to be related to a certain DLL that was also crashing Mozilla Firefox. They ended up finding a way to block the DLL from loading so we’re working on doing the same. Sorry for the problem.

It has been three weeks. Any updates on the progress?

I tried uninstalling GlassWire, rebooting and reinstalling. Idle monitor keeps on crashing.

Is there at least a way to disable the generation of dump files? Until you get the issue resolved?!?

By now I have deleted over 20K of those things (around 1.4 TB of dump data) - by hand! This is getting rather ridiculous and stupid.

The fact that GlassWire just dumps them on the desktop is not helping matters at all!

It is annoying to extreme, not being able to select them all with crtl+a and just delete. Within 10-15 minutes my desktop is full of dump files that happily plant themselves between icons and files I’m working on. So I have to go one-by-one to remove them.

(In addition the process grabs precedence from other windows functions like file renaming, managing clipboard etc. so if you do it while a dump happens, that process just closes. Leaving you with an empty or partial file name or whatever stuff you had in clipboard.)

@bernard Nahimic emailed us recently. Can you download their latest software (if you have it installed) and see if it solves the problem?

Sorry for the dumps also.

As already stated in the OP I do not use Nahimic!

I never have - Nahimic is not installed on my system and I see no reason to start using it since I do not have any MSI components.

The e-mail I recieved (in May) from glasswire help, after sending in some of the dumps said:

“This seems to be related to a DLL for media from Asus. Mozilla Firefox had similar problems with this dll and they have tried to block this dll from loading with Firefox. We are investigating how to do the same. When an update is ready to test we’ll send it your way.”

Sorry, I missed the part about not using Nahimic.

We’re working on making an update with a fix similar to what Firefox did where it avoids loading this DLL files. It probably won’t be out in this next update, but it should be out in the next one. I apologize for the delay.

Hi -only for your information-
after update WinX pro (21H2) with KB2565063 (MS VisualC++ Servicepack …), I have also many dumps and a reinstall was not helpful - but i used only the free version.
I hope there is no new workload in progress.
have a nice rest of the year