GW is blocking host process


I have Windows 11 x64 running and use GW 2.3.
I want GW to show me all internet access from every program that want it. So I switch on the Firewall toggle and select “ask for permission” (sorry I use a foreign language)

The problem is, when I switch to “ask for permission” mode, GW blocks all access from the host process and I can´t grant the access cause each app and process has a gray flame icon. :disappointed_relieved:

I have already uninstalled GW and process a new, clean install, but this behavior still exist.

How can I grant several apps and services the internet access in GW?
Why are all flames are gray?

Thanks for any hint



Sorry for the issue. Is it possible the GlassWire firewall is switched to “off”, and that’s why it isn’t working? Please click “Off” at the left middle, then it will turn on.

Do you have our paid or free version?

no no… when I switch OFF the GW Firewall, everything is working fine.
The problem is when I switch it ON, all access to Internet is cutted off.

Anyway, you can´t switch to the option “ask for permission” when the GW Firewall is switch off :thinking:

Again: When I switch on the GW Firewall toggle and select “ask for permission”, my internet access is cutted off cause the host process can´t pass.

For my understanding, everything should have the orange flame icon per default, and when I switch it off or grant the permission for it, it should pass the GW Firewall.

Question: how can I grant a app or a process when it´s not shown in the permission popup?

and yes, I have the paid Enterprise respectively Pro Version running

Strange. Are you running any other firewall software? If so can you go to add/remove programs and remove it?

Next go to add/remove programs and uninstall GlassWire.
Then go to the Windows Firewall control panel and click “restore defaults”.
Now reboot - IMPORTANT
Now please reinstall GlassWire with “clean install” and “reset’ firewall” checked (you will lose settings/history)
Now turn on the firewall and “Ask to connect” and let me know your results.

nope, not working.
I have done your mentioned steps and every constellation is working except the “ask for permission”

I switch the GW firewall toggle, and I can only block all or “click to block”, but when i choose “ask for permission”, all internet is cutted. It seems that “ask for permission” does the same as “block all” :frowning:

When I switch to “ask for permission” some apps are showing up in the popup and I can grant the internet access, but the crucial Windows apps and services like the Host process, does not appear in the popups.
I can see it in the list in GW, but I can´t grant it, cause it does´nt ask for permission. So it´s a kind of loop :disappointed_relieved:

I can assure you our software does not work that way. I apologize for the problem.

Is it possible you are using a VPN, or some sort of app that is routing all network activity through itself that’s blocked? For example, maybe your ISP routes all your network activity through it?

Could you message me privately with a screenshot of your firewall so I can see what you’re seeing?