GW update mechanism won't work

Hi! :wave:

On my GlassWire instance I never get update alert. For example my version of GW is 2.3.397 and latest is 2.3.413. I already reinstalled/restarted of GW and it still not inform me about latest updates. Any hints? :upside_down_face:

I running on Win 10 Pro with latests sys updates.

You might have disabled notifications :slightly_smiling_face:

1 Like

Hi @cindyforcia
Where is this setting? In GW settings or in Windows settings?

I think it’s in windows. :smiley:

Hi, on my [Windows] → [Settings] → [Notifications & actions] I don’t have any GW setup or switch. Maybe I looking on wrong place in Windows settings. Any hints? :wink: Thanks!

…Bump… any sugestions? :wave:

Windows notifications don’t matter. When this worked it was the program itself issuing the update notification. I don’t recall that it sent anything to the notification area.

• GlassWire > Settings > General > Enable tray notifications

• Windows > Settings > System > Notifications & actions

FYI: these two are completely different animals. A software developer can use either or both.

To the best of my recollection, GW never hooked into the Windows’.

An auto-update feature was added to GW in v2.3.363 (10/25/21) and in the latest v2.3.413 (05/24/22), “Fixed an issue where auto-updates can sometimes fail.”

I believe I remember auto-update just ran whether one wanted it or not by displaying a modal window having “install now” or “later” options. This was changed in v2.3.374 (12/09/21), “Auto-update improvements and fixes, as requested by users.”

I’ve always just downloaded the latest GlassWireSetup.exe and run over the previous and will continue to do so.

But to save my life, I can’t find anywhere in GW Settings where one manages the auto-update feature. I must have disabled it somehow, sometime. So, no method to re-enable it??

Install 2.3.413 manually: “Fixed an issue where auto-updates can sometimes fail.”

Might help. Might not. The nature of that fail isn’t enumerated.

Either way, you’ll get other important fixes.

Cheers.