GWIdleMon high CPU usage

since the first version I installed few months ago Im dealing with Glasswire eating all of my cpu time even while connection is idle.

When I run Glasswire, everything is ok, but after some time (and I suspect after my connection gets disconnected and then connected again - I use dial-up mobile 3G connection on my notebook) the cpu consumption raises and it nevery drops. Closing Glasswire from tray does not help, I also need to kill the glasswire service every time.

This is the same even in the new 1.0.40, I noticed that you reacted to similar reports in the forum in the way “cpu consumption and resources usage will get better in new versions” but this seems that that is some sort of bug, not performance issue, it didnt get any better with new versions of Glasswire.

The main suspect is the GWIdleMon.exe - thats the exe that is eating all the cpu. I cannot post screenshot because “New users cannot upload images” (?)

Thats funny on my PC =GWIdleMon.exe uses --0.01 % of my cpu. Even taking into consideration the difference in cpu speed etc between yours and mine thats still a large difference .It occurs to me that if you have had the old version and just updated over the top of the new one maybe the earlier one has some corrupt files when installed . I would try removing GW completely and make sure its all removed and then re-install it and see if that makes any difference.

1 Like

Thats very unlikely, some mysterious corrupt files are usually not the problem in my experience. And I tried it - it didnt help, after hour or so, CPU usage of GlassWire.exe and GWIdleMon.exe went high.

It’s much more likely that this is same issue as described in “Possible incompatibility with Networx” which I recently discovered. (I cannot post links, new user, not full citizen)

Im also using Networx, when I tried to stop Networx, CPU usage (and high IO rate which I wasnt aware of before when I created this issue ) of GWIdleMon dropped immediately, GlassWire.exe is still consuming all processor power and IO read rate is 8MBytes/s though.

Now I tried to restart Glasswire with Networx disabled and will see if the high CPU usage will return. But it seems there is really some issue when Networx is running on same os.

1 Like

I can only go on information provided ,if some is held back then a complete answer cant be given . You should have mentioned Networx had caused it to happen and said so in your post.Its easy to criticise when vital information is held back and the “mysterious files” comment shows you have not encountered every type of fault condition in a PC . Corrupt files loom large in faulty programs dont take my word check on the web. Networx I got rid of as a hacker used it to cause me problems .

I couldnt mention Networx issue and didtn hold anything back, because as I wrote in my last post (“which I recently discovered”) I wasnt aware of Networx conflict possibility, I did find it in the forum right before my second post.

I wasnt criticizing anybody or anything, I was expressing my opinion and I didnt jump to conclusions about anybodys experience with fault conditions as you are. In MY experience as a developer who solves errors every day for more than 10 years , sources of problems are more often very concrete, every time I became suspicous about some unexplainable broken files etc, I was wrong.

Getting rid of Networx is not a solutions as for many years is perfectly functional software and apparently there is some issue between these two - and issues can be mostly solved.

1 Like

We feel confident we solved any incompatibilities with Networx. Please upgrade to the latest GlassWire version.

Great, thank you very much!

When you wrote “to latest GlassWire version” I thought that there is some new version after 1.0.40, but as I wrote in my original report I was running 1.0.40 already.

I think it is not entirely fixed. Also when I woke my notebook this morning, GlassWire cpu usage and IO rate raised again - it is eating all cpu and has very high IO rate although there is very little or none network activity

I tried to post image, then the link to image but neither is possible, Im new user, annoying :frowning:

Would you be willing to share what other software you are running so we can try to recreate this? Feel free to email it if you want it to be private.

No problem at all - I dont have a lot of software runnig I guess, the list of software which is running all the time:

BOINC client
ESET Nod32 antivirus
ArsClip (clipboard history utility)

As I wrote (post 8d ago), it seems that maybee it is related to NetWorx somehow. To sum it up, here is the description of the problem, it is everytime the same more or less:

  1. I started GlassWire after os start, everything was ok
  2. after some time (> hour I guess) GWIdleMon.exe and Glasswire.exe CPU usage went high
  3. then I stopped Networx, CPU usage of GWIIdleMon went down to normal, Glasswire.exe CPU usage stayed high
  4. then when I restarted Glasswire.exe, it was ok again

Then I started Networx again, CPU usage was ok for some time, then I closed my computer (it’s notebook) and left it sleeping during whole weekend and monday. After opened up notebook this morning, CPU usage of GlassWire.exe went high again, GWIIdleMon was ok.

The sleep-wake scenario was today’s speciality, I dont usually close my notebook, it’s runnign at my workplace all the time and generally it seems that this problem appears always of some time when GlassWire is running.

Im not sure whether it can be related to my internet connection, it is made by 3G modem so the connection is sometimes dropped and I had to dial it up manually.

I know it sounds quite complex, I want to try it at home also because there it is more simple setup (same software running, no 3g dial up there) but I didnt have time for this yet, Im very busy these days.

I forgot to mention that there are few Lenovo services running as this is Lenovo notebook, but I keep their count at very low level, I uninstalled nearly all Lenovo preinstalled software.

We’ll do some testing and try to recreate and fix this. Thanks!

I tried 1.1.15b but it is still not solved :disappointed: Glasswire GWIdlMon.exe is on 100% after some time and it still seems it has something to do with Networx.

Well let’s just wait for a week
they are really working hard right now…
they are planning to release an update on next week or so
So let’s just wait …PATIENCE IS EVERYTHING

I tried last 1.1.21 beta version and unfortunately problem persists. After while GWIdleMon CPU usage and IO rate went through the roof. After I closed Networx, GWIdleMon CPU usage went down but it looks Glasswire.exe took over and CPU usage and IO rate is at 100% again even with Networx stopped.

Networx running:

after I stopped Networx:

update - after I closed restarted Glasswire (through systray icon, Exit and starting again, I didnt restart the service) it ran hour or two without CPU exhaustion but then again, CPU usage and IO for GlassWire.exe raised.

I displayed the threads and it showed the one responsible if it will help:

Wow thats a lot of CPU usage mine never changes from 2.2 % -EXE and I/O from 16 Bits to peak of just over 1 Kbts . I am beginning to suspect you have a rogue Windows update somewhere while not allowing updates (has for me ) stopped many Windows process faults like that I realise its not for the majority but it cut down the cursing and HBP for me as in the past I was blocked from the Web/blue-screened and umpteen apps blocked that ran for years. I cant get Firefox to run properly in windows due to an obscure hidden registry entry that is also scrambled with numbers/letters that cant be unscrambled . No problems on Linux on same machine though .Makes you think ?