GWldlMon.exe.dmp files on my desktop

I keep getting .dmp files created on my desktop from glasswire. I just reinstalled windows with a new mobo/cpu/ and memory and since the reinstall i keep getting these dump files. More annoying then an actual problem. I tried uninstalling the program and reinstalling and it is still doing it. It has even created 2 files in the time it took me to write this post.

Sorry for the problem. Could you try an uninstall/reboot, then reinstall our latest version with the “clean” option? If it continues could you email us the dump files so we could investigate?

Yea I have reinstalled it twice and it is still doing it. I’ll send you guys the dump files. I have literally over 30 haha. Hope you guys don’t mind so many files

You can send the 3 most recent if you want.

I emailed them over to I’m not sure if the email sent or not. I sent it through gmail. The files were to big for email so i had to upload them on google drive in the email. Let me know if i need to send again. Thank you for your time.

@mint We found the issue seems to be related to NahimicMSIOSD.dll. Can you try uninstalling that software and see if it solves the problem? Please contact them and report the problem if possible. Thanks!

I had uninstalled and reinstalled twice. The problem though has seemed to fix itself?? I never reinstalled a third time but it stopped creating dump files on my desktop. So overall I hope if anything it helped you guys out for any future issues. Thanks for your support much appreciated.

That’s good it’s fixed. If it happens more try temporarily removing Nahimic and see if that helps or not.

Yea actually i think that program was the issue. Its the default audio software that came with my new motherboard. I use a virtual audio cable program so i don’t use it anyway. I started shutting it down and that is probably why i’m not getting the dump files created anymore. Awesome thank you so much.

Same issue as mine here : Glasswire 1.2.54 crashes, dmp file on Desktop [cannot post links as I am a new user :(], only that I actually want to use Nahimic.

I am hoping that Glasswire team can actually figure out this issue as this did not happen with the older versions of Glasswire.

@abesh Someone reported that they uninstalled and reinstalled Nahimic and it fixed it. It doesn’t seem to be something we can fix without Nahimic’s assistance.

I did :slight_smile: It worked fine for sometime and came back when I reinstalled the new version of Glasswire. After that I uninstalled and re-installed Nahimin quite a few times without effect :frowning:

@abesh OK, we plan to email Nahimic to see if there is a solution to this problem. We don’t do any audio changes so I don’t know why their audio software would cause GlassWire to crash, very strange.


Nahimic sent us an update for our users to test today, please try it.

After several days of testing I can confirm that there are no more dumps. Thanks guys!

This dump issue is still happening. 3 times in the last week. More before that, now deleted.
I am sending the latest file to bugs@ shortly.
I am running v1.2.74 but I dont use Nahimic.
Hope you can help.


Thanks. I got your email and I’ll send some question so we can figure this out. Sorry for the problem.

Did you guys ever find a solution as I’m getting the dump problem as well and I don’t use nahmic also


Could you email us the dmp files? It would tell us what’s wrong. You may need to put them on a cloud service if they are large.

I’m suddenly having this problem years later. Just out of the blue glasswire started dumping these dump files all over my desktop. 9 more have been created in the time it took to find this page and shows no signs of stopping. As for sending the files, they’re around 55mb EACH, so they’re kinda screwing me here and I don’t think my email would send a file so big.