In the settings app unlock does not stay unlocked

I have tried everything in this forum but nothing seems to work it always reverts back to locked.

Thank you for any help,



If you press the buttons in the order shown in the image below does it solve it? You should go to the top left GlassWire menu and choose “settings” to find this window.

Yes I have tried that and, reinstall it many time, I installed it then restarted first than ran the program but to no avail.


Are you admin on your PC?

1 Like

Yes I am the admin of my pc.


We’re preparing a major GlassWire update that should be out soon. If the update still has the issue please let me know and we can make a logging version for you to see what’s going on.

Do you ever notice any issues being admin on your PC? Are there any unusual security settings that you have made with Windows?

I have not seen this issue so I am not sure what to suggest.

I have the same problem. I tried the suggestion. No luck. I am using version 2.2


I am using 2.2 and I cannot recreate this, however I could not recreate this with 1.1 either.

Could you double check something for me?

  1. First click “unlock” here.

  1. Now uncheck this box here.

  1. Now press “OK”.

  1. Now re-open GlassWire’s settings and see how it looks. Did it save those settings or no?

I repeated this entire process and it saves the settings for me with no issues. These are screenshots from my own GlassWire install of 2.2.

If it does not work for you, are you admin on your PC currently or are you a user?

This was the key and my confusion. Works fine now. Thanks


Thanks for your feedback. We will see if we can improve this usability in the future so it’s more clear.