Increased CPU usage from GlassWire Control Service

Hi
Recently i have noticed an incease in CPU usage when my home server is idling. It is down to the Glasswire Control Service. It hovers around the 30-35% all the time.

If i restart it is fine for a short period and then it just increases and increase until it gets to the 30-35% mark

The machine is a windows 10 machine that is on 24/7 running plex and also 2 VM’s one is a PFsense firewall and a Ubuntu Server running a web server in a DMZ from PFsense.

I did wonder if it was the VM’s but if i shut them down the CPU usage stays the same. Obviously it is not as if it is running 100% CPU but it use to idle around the 3-7% idle.

As anyone else had something similar happen with the control service?

Thanks

Wayne

@waynage

Sorry for the issue. If you go to our top left menu and choose “About”, what version of GlassWire do you use?

Do you use Bittorrent?

Hi Ken

Thanks for the quick response, i am running version 2.2.291.

I have just tried a fresh download from the website and reinstalled just to make sure i was on the latest one and it is still doing it.

I have cleared all the history.

I do not use Bitrorrent on the machine.

Thanks

Wayne

1 Like

Email me and I can send you a beta version that some other users are testing. It has some major resource usage improvements, and we found a bug that can cause this issue with some hardware types.
https://www.glasswire.com/contact/

Make the subject of the email a link to this thread. @waynage

Thanks Ken, i have sent the email to the help address as requested.

1 Like

@waynage I replied, please test and let me know your results.

Hi Ken

I have tested the beta version and it is better, i cant remember what it is supposed to be like on a good day but it has halfed:

But it is still one the top for usage, considering i am running 2 VM’s and they are only using 0.3%. There is little traffic either, only reporting 114MB since i installed the beta, so it is not as if it is busy logging a lot of stuff. Would you say this is a more normal amount of CPU usage?

Many thanks

Wayne

Thanks for testing.

I think 45MB is reasonable for what GlassWire does. If it’s too much for you then you could use our Lite version instead that does not keep track of hosts.
https://blog.glasswire.com/2020/10/06/introducing-glasswire-lite/

It was more the CPU usage when the machine is idling more than the memory.

Thanks for the link to the lite version.

Regards

Wayne

Sorry, I should have paid better attention. Yes, the CPU usage you were showing is excessive in my opinion. Let me know if the Lite version solves it or not.

Hi Ken

I have left it for a while and could hear the fan was on so remoted on to have a look and it is high again, this is the lite version as well:

Not sure what else to do and have disabled it for now.

Thanks

Wayne

1 Like

@waynage

Could you send us logs?

-Stop the GlassWire service via the TaskManager. (it appears it’s already stopped for you)
-Open C:\ProgramData\GlassWire\service-full (or -lite, depends on the version the user runs).
-Open glasswire.conf as administrator.
-Set the following parameters and save the file:

LogLevel = 255
LogEnabled = true

Start the GlassWire service via the TaskManager, or reboot and see if it starts again.
Repeat the problem.
Send us the logs from C:\ProgramData/glasswire/service-full/log (or service-lite, depends on the version)

Please email us the logs along with a link to this thread.
https://www.glasswire.com/contact/

@Ken_GlassWire log file sent :slight_smile:

1 Like

@waynage

Our team will review the logs, thank you!