Issue with pulling the mini viewer between different resolution monitors

Just downloaded this software and its nice looking and works great! But I have run into a problem where id like to keep my mini viewer on my 2nd monitor (4k 60fps) and when I move it from my main monitor (1080p 144hz) it crashes. It seems like it doesn’t know what to do when it changes resolutions? not very sure but even when I open GlassWire from my 2nd monitor the mini viewer defaults to my main and when I drag it over I get the same problem and it crashes. Any advice? id like to run games from my main and keep the mini viewer on the 2nd but it seems I can’t right now. Thanks in advance.

I have a video showing what it does but i cannot post links because im new.

Moving the viewer between monitors at different resolutions used to work without your problem so that is unlikely to be the cause as there would be many other users complaining.

There was a potentially-relevant problem when the viewer was not returning to the previously used position.

Monitor order in Windows was a factor in that bug so maybe that is a factor here? To test this, you would make your second/4K monitor the primary monitor in Windows and see if the problem still occurs.

@skelr

If you go to the top left GlassWire menu and choose “About” what version of GlassWire do you have? Do you see a .dmp file on your desktop after this crash happens?

i am having the same problem, i have glasswire elite 2.1.167

this happen after i upgraded from 2.1.166

@SirNicolas

Could you send us some logs?

Stop the GlassWire service;
Copy log.conf to C:\ProgramData\GlassWire\service
Start the GlassWire service and reproduce the problem.
Send us the logs from C:\ProgramData\GlassWire\service\log

Log.conf should be a notepad file called exactly “log.conf” with these two lines only:
log_path=c:\programdata\glasswire\service\log
log_level_file=-1

IMPORTANT: log.conf cannot end in .txt so please be sure to remove that extension on the file or this will not work.

Our email is here, and please link to this thread so we know what the logs are for.
https://www.glasswire.com/contact/

Could you tell us what resolution each monitor has, and what OS version you are using?

main monitor has 4096x2160 (4k) and secondary 1080p
log files sent but i don’t see anything related to the UI in there

i also sent a video using dropbox so you can see what we are talking about

Thanks, I will send it to our team.

greetings
i had no response for a month about this even if i send the details

@SirNicolas Did you get a response at all? If not perhaps the file was rejected some way?

Or did you get a response from me and I have not responded back yet? If so the reason is probably because we are working on a major update for the desktop where it’s very unlikely this issue will still exist. The update should be out next month. I apologize for the lack of communication.