Issues signing in after glasswire 3.0 install

I have had Glasswire Basic for several years and have 74 days left. I installed Glasswire 3.0 today without incident with respect to installing. Things seem to operate fine except I can’t sign in but have access to the program. Says it will send instructions but they never arrived. On the contact page twitter and two icons next to twitter work. However, below that are several email addresses that do not work so I can’t make contact. All security and blockers are off. This occurs in BOTH Firefox and Chrome. No password instruction sent. I use Google Mail. Here’s the kicker; when I go through the program to community forum and sign in on that site password sign in works. I want to boost my basic, but not now if I can’t get this solved. Any help would be appreciated and perhaps check those addresses that didn’t work. Thank you

1 Like

Forgot to say use Dashlane also.

Hi maicokid,

Please can you email to confirm the email address you have used to create the account, along with error which happens when you try to log in?


Katie, thank you for answering my post. Hopefully this will help. PS I tried sending to the address you suggested above, but under help the URL for contact didn’t work nor did @bugs,@activation etc. on the contact page. Check my original post for details above. I now see you sent from a no-reply mailbox so I have no choice but to try this forum reply.

It may be best to explain how things are now. Again, several years ago I purchased basic and it was fine until I tried signing in yesterday and the error came saying “invalid email address or password” after several attempts. I use Dashlane for passwords. Finally gave up on that after the URL on your contact page for 4 different addresses did not work including the one you are now suggesting. See original for more details if you want on that. So I decided to create a new account using the same email address with a new password and it worked… I also wanted the $40.00 upgrade and started the 7 day trial version but at present it continues to say I have basic. Does it change to pro after a 7 day trial or what? I also added Glasswire to Google Authenticator 2F during the creation of the “new” account without a problem. At present the sign in/sign out works now. My goal is to upgrade at the end of trial, that all features work, and that pricing and upgrade status are correct. I have 0 complaints about the software and it gives me good information. If you need more let know. I await your reply with baited breath. Thank you and be safe out there.

I have the same issue. Have Glasswire Pro version and upgraded to GlassWire 3.0. When I try to sign in receive error message wrong user name or password. When I say I have forgotten my password I never receive a code from Glasswire. Thanks for any assistance you are able to provide. Cheers


Hi @Dewbear

Sorry for the inconvenience caused!

For our engineers to look into this issue, please can you email with the following information:

  1. The email address you used to create the account
  2. The time zone you are in
  3. The time and date (as close as possible) that you created the account
  4. Logs


When I created the new account I used the same email address. I had with the original account and it was accepted. I did create a new password for it. We are on central standard time right now in the US. Was created on Nov. 16th this week between 1000 -1600 CST. Again what does the information say is the status of my account plan etc. Thank you.

Katie, again I am unable to respond to the emails you sent to my email address because your sending from a no-reply email box. Thanks

Are you still out there? Please answer since there is no chat or phone number. Thanks

Hi @maicokid

Please can you email to confirm the email address associated to your account?


Have read what I wrote ?

Is you support even functioning? It taken more than 1 days to get help and unfortunately not much. Are ou people having issues.?

Hi @maicokid,

I have seen that your email to support have been answered by our team. Is there something more specific I can help with?

To confirm, you have a paid license called “Basic”. This is one of the old licenses which you can still use on v3. The new license are called Premium and are part of Plans. See more about this here: Premium Subscription vs Legacy License



I am having the exact same issue.

Details have been email to “help”.

It just crazy to remove a feature after a user has paid for it and put their network security as risk…

Hi @gary1001,

Just to confirm we haven’t removed any of the features for the old license types (Basic, Pro and Elite). We have only added more features.


1 Like

I am unable to respond to the emails you sent to my email address because your sending from a no-reply email box. Thanks

Hi @niftiitimp,

You can reach our team on this email address:


A post was split to a new topic: Changing legacy license to new Premium license