Latest installer fails to install a working program [win10 upgr]

Windows 10 Home. Upgraded from 8.1. (Years ago).
Windows updated: To most current.

We uninstalled the last GlassWire by Revo Uninstaller. (as a last resort because we wanted to keep the red dots!!)
All traces (pc+reg) removed on medium/moderate lvl removal. [RevoScan during uninstall]

We tried reinstalling it to it’s own folder.
The previous install seemed to have installed itself in the download folder by mistake or bug.
When we reinstalled it 2 weeks ago, we had all sorts of issues with one of them trying to keep previous install information, yet when reinstalling and chosing the correct folder, it yet again installed itself to the download folder (in the same GW subfolder).

We have multiple users on that pc, and even though Revo installed it on one user, on the other user we still had the program lingering. Revo usually first alway tries and uses the program’s own uninstaller. So the uninstaller may have a flaw in it (too), preventing searching the entire pc to uninstall it from ALL accounts.

Aside from this lingering copy on another account after uninstall, at the reinstall it reinstalls it again and again in the download folder. And to make matters worse… THE PROGRAM DOES NOT LOAD!
Like in the comment in another thread (about the program refusing to install itself), we too get the same error popup about that missing dll!! (I forgot the name of the dll, but it was a dll, 100%!)

So that pc now got a non-working GlassWire. We could go back to an older version (If installing that is not impossible now too), yet every day that version will get the nag-popup to upgrade ofc…to a non-working version!!! :stuck_out_tongue:
Clearly unacceptable, and unworkable.

Kindly look into it. We not got more users having this same problem. The new download=BROKEN! :slight_smile:

(Tip: What happens to this dll when at one user [adm/adm] the program get’s uninstalled, and on another it is not?)

Kindly greeting,


Unfortunately third party uninstallers often cause this issue because they fail to remove our driver. Our driver then stays installed even after the uninstall because third party uninstallers don’t know how to deal with drivers, so GlassWire can’t work on reinstall.

You can back up your data with GlassWire before starting this process.

To solve the issue install GlassWire again with its “clean install” option. If it still does not work (due to the driver issue), then you should go to add/remove programs and uninstall GlassWire now that way.

Now reboot - IMPORTANT - It should make sure the driver is removed.

Now download our latest version and check the “clean install” option once again. The issue should be solved, but if it’s not please let me know.