Majority of upload data not being counted

Only one app appears to be registering accurate uploads in large amounts. I run backblaze and am seeing data upwards of 200 gigs a day but the app says 72 MB

Confirmed again with speedtest app that shows download but doesn’t register upload at all.

Can provide screens if needed.

@maxatv

If you go to our “Usage” tab, can you tell me what your settings are there?

traffic

I ask because some backups apps will use local network activity between devices. For example Dropbox often does this so it doesn’t have to download the same files over and over using the Internet.

My settings match your screenshot

I can confirm I also have this issue, GlassWire isn’t recording uploaded data for most connections for me. I don’t really understand why some connections do show some uploaded data but the vast majority show 0 bytes uploaded.

Very strange! We use a Windows API for data collection. It’s used by every other network monitoring application.

You can test it like this https://blog.glasswire.com/2016/06/15/glasswire-network-monitoring-accuracy/.

@Thinking Could you give more details? Thanks.

Glaswire just appears to not register 99% of upload traffic. Below is screens of a speet test and download gets measured correctly but upload not a single hit. This is also not fixed by reboots, or switching networks ex, hardwires vs wifi.

gw2

1 Like

@maxatv

Do you have some apps set as Incognito? Perhaps that could explain it.

We could not recreate this.

I’ve checked and confirmed nothing is incognito, all other machines I have installed on work fine

1 Like

Have you restarted Windows since installing GlassWire? That has often corrected any issue like this.

1 Like

@maxatv 's issue might be different but at least for me this issue has persisted across many, many, many restarts and even two completely clean Windows installs.

Edit: I have tried a lot of things but the only pattern so far I noticed is that it seems to work for a bit right after restarting but then quickly new connections don’t show upload data.

Edit 2: This alongside the issue with noticable CPU interrupts when a lot of data is being transmitted (~>100mbits) has been my two main issues with GW.

@GlassWire devs, how is the backend rewrite coming along? I remember something was said about end of 2019 but I haven’t heard anything since.

1 Like

Likewise, I have restarted many times and clean installed. It was working for several years on this machine so that leads me to believe something update related either to windows or any software on my machine.

It was working fine for years for me as well on the same machine.

I actually suspect some involvement of the ethernet/network adapter as I don’t see the issue when using GlassWire in a virtual machine (forgot to mention it before).

Do you have some kind of unusual network settings, or maybe you both use a similar type of VPN that can somehow hide traffic somehow? Just thinking…

It’s very strange because we cannot recreate this (as shown in the screenshot above) and to be honest I do most support and I don’t see emails about this, unless it’s a misunderstanding. As mentioned previously we use a Windows API to collect data and it’s unlikely it’s broken.

Maybe if you guys feel comfortable you could privately message each other in the forum to see if you are both using some similar type of network, security software, vpn, or some other thing that you both have in common? That way you don’t have to post about your private setup to the public forum.

I do not believe so, and if I did it’s been that way working for years. The only changes that happened to stop functionality were windows KB updates for January. There is no VPN in use the majority of the time, and other devices on the same network use glasswire fine. Still leaning me towards an update breaking something, but happy to try and submit any type of logs or info that may help.

I’m hardwired but switching to wifi doesn’t change anything.

Also have tried clean and clear installs including resetting firewall to default state and still no joy on upload data

@maxatv

Well, it’s not good if GlassWire cannot read data. I just tried this test once again on my own personal PC and it’s completely up to date with Windows 10 and it worked fine for me also.

Please note that we’ll have a completely new update out with a completely new backend in a week or so. Please be on the lookout for our forum announcement. If you still have this issue with that update then we’ll be interested to see how it’s possible and we may ask you to test a logging version of GlassWire if you are available to do so.

The logging version will keep logs on your own PC that you could email us if you wanted to find the cause of this issue. I’ll have to ask our team if it’s possible to make a logging version to detect this issue or not since it seems fully controlled by Windows itself. Maybe if both people with this issue tested a logging version we could see what app could be responsible, or perhaps it’s some type of unusual VPN setup or unusual network settings that control how your data is used somehow.

Also it probably wouldn’t hurt if both of you did a Windows Defender scan, or some type of antivirus can just to confirm your PC isn’t somehow infected with something.

Yes sir sounds good! will try new version and if not happy to work with GW and Mr. Thinking to help find the cause

2 Likes

I also have the same issue on my desktop PC. Since the Android beta update has arrived, will Windows update be available this week too?

@Kultigin

Could you email us details on why you think you are experiencing that?
https://www.glasswire.com/contact/

The Windows update should be out soon I think but probably not this week.

I have no idea why do I have the issue, I don’t have it on my laptop. However I have different issue on my laptop. I will contact the link you mentioned if my problems still continue after the next update. Thanks for your answer.

1 Like