Make GlassWire stop disabling "Block All Incoming Connections" firewall setting


#1

Basically what it says in the title:

Setting can be found in the advanced firewall settings or Windows Defender network settings. GlassWire disables that setting on firewall changes and on system start.


#2

Thanks for your feedback. This is an option on our todo list.


#3

I found a temporary workaround until it is fixed:

Requirement: A Windows version that has the group policy editor (others may be able to do it via regedit, not sure what the key is tho)

Go to: Local Computer Policy -> Computer Configuration -> Administrative Templates -> Network -> Network Connections -> Windows Defender Firewall -> Standard Profile

Now enable “Do not allow exceptions” and “Protect all network connections”. Done! It overrides admin permissions so GlassWire can’t disable it.

Note: To verify it works, use “Windows Defender Firewall with Advanced Security”. The “normal” Defender UWP window doesn’t correctly show that it is forced on.