My Glasswire stopped working too, but different (Win10)

Sorry I have so little info to give you to help find problem, it’s so odd I’m half wondering if it’s Win10. Anyway, I’ve been running GW on this Win10 for a while, no problems. Updated a few weeks back, ran fine still. Then a few days ago I noticed it had stopped appearing in tray. Task Manager showed it still running, but w/o tray I couldn’t open GW’s window, so I can’t tell you the exact version.

Killing all instances with Task Manager and re-running didn’t work, same issue.
Killing all instances, stopping all third-party programs and then trying a re-install didn’t work, it hangs at 5% where it tries to uninstall old version (option to cancel is also grey’d out and has to be killed with TM.) A clean re-install (with that option checked) also hung.
Then tried using Win10 to uninstall GW, hung again.
Manually deleted the Glasswire folder under Program Files, then went and renamed the Glasswire folder under AppData to something else. Tried a fresh install (v1.2.64 fresh download) and it got most of the way done but hangs at trying to execute GWInstST.exe "www.someting I can’t read the rest. The option to cancel the install is grey’d out here too, so I’m going to have to use TM to kill it.

Going to uninstall it again, then try a reboot, then a clean install (didn’t think of a reboot until just now…)

EDIT: Install worked after a reboot. Seems alright now.

I’m glad it’s working now and the reboot helped. If this happens again please let us know if you’re using any third party security software or utilities so we can see if something could be interfering with our install.

Glasswire stopped working again. Under Task Manager it is there, but no longer in tray, so cannot open window of it. The third party security software I use is Bitdefender (, that’s it, I have a pretty clean system.

Also under Task Manager there are about 40 instances of “GlassWire Computer Idle Monitor” (after a computer uptime of about 3 hours.) These do not die when you kill the main Glasswire process and have to be killed individually.

I’m thinking I have to go find an earlier version of Glasswire at this point…?

OS: Win10

We think we have found the cause of all these 40 idle monitor instances. Please email us with a link to this thread and we may have a new version for you to test

Using: 1.2.64b

Confirming that if Glasswire doesn’t run (or stops runninng), a reboot on Win10 can fix it.