New Ports Display on Firewall Tab?


#1

I installed GW 2.1.140 today. Unfortunately I am unable to see how to display the port that a program is connecting to on the Firewall Tab. Is there a special setting I am missing? Is there a discussion of this new feature someplace? Thanks.


#2

I can see them in the Firewall Tab in the Hosts list which is the second column:


#3

That’s interesting and looks great. I have no hosts appearing in my Hosts list at all. Maybe nothing at all is connecting? It’s difficult to tell. How might I test this? Thanks.


#4

I just now saw one, it was very brief but did show the port number. It seems like I should have more hosts connecting. I’m not certain. Thanks for the screen shot.


#6

The problem might have been that I had GW set to Ask To Connect. I tried changing to Click To Block.


#7

That seems strange but you might not have any persistent (keep alive) connections. I’m running apps and processes that do:

Push notifications:

  • Firefox
  • Discourse forums

CDNs:

Streaming

  • Host Process for Windows Services to Chromecast

#8

It is true that I have somewhat fewer network connections going on. FYI: If I do a “Search Online” for a host that also has a port number appended to it (with a space and colon), the Hosts lookup fails. To get it to succeed, I have to delete the appended space+colon+port number.


#9

That would be expected that the port causes the lookup to fail. Good pickup of that bug.


#10

Thanks for noticing the port bug! I think we can fix it on the web-side so no software update is necessary.

Also, for anyone who does not like the ports showing, just go to the general settings and you can turn this on/off whenever you want. This feature is optional.


#11

@csdfg2

Please try it again now, I think we fixed it.


#12

Yes, it does appear to be fixed. Thank you.


#13

Where are the ports supposed to be displayed?? I turn the feature on but I can’t see any ports.


#14

@3jf9fab41

Please check the Firewall tab. We don’t show them everywhere yet, to keep resource usage low.