New user. Seems that glasswire is preventing net access

Hi there,

Extremely long time user of Comoro fw here. After switching yesterday to gw, I have been unable to access the net on my desktop. At first I thought it was the pia client update. Uninstalled it, still no joy. Oh but I can access the net in safe mode. Obviously my the wireless is working on my router. So I tried checking the connection through the win 10 troubleshooter. Apparently I’m connected to the net as it says in the status. But it tells me that my modem is experiencing connectivity problems. As I only have one cable to connect the wall, I can’t check that. I swapped out the desktop to router, and still nothing. Cables are only a year old.

So question, what has gw done?


It’s rare for GlassWire to cause connectivity issues because we use the Windows Firewall API for blocking. This API is built into Windows itself and exists before GlassWire is ever installed.

The Windows Firewall API is great because it uses almost zero resources and it can block even if GlassWire is killed by malware, or even during bootup before GlassWire starts.

Let’s quickly make some changes to Windows to solve your problem, or at least rule out that the problem is caused by GlassWire.

  1. Go to add/remove programs and uninstall GlassWire.

  2. Go to your Windows Firewall control panel and choose “restore defaults”.

  3. Reboot

Is your issue fixed? If not then it may be related to the previous application you were using. Maybe it was not removed all the way? I think that app has its own blocking system so maybe some parts of it were left behind when you switched to GlassWire?

If the issue you had is fixed, when reinstalling GlassWire choose the “clean install” and “reset firewall” options in our installer.

Hi ken and thanks for the reply.

Ok so yes, there was some leftovers from the comodo install. Which is sorted now.

I hate to tell you but, but the problem remains.

I’ve got access with gw to the net. When i installed the pia VPN client. I’m getting an unable to connect to the any vpn servers.

I haven’t checked the forum for this yet. Is there any known conflicts between gw and pia?

Otherwise I’ll contact pia for a way to uninstall pia and any leftovers that remain. And then try again.

Any help anyone can give would be appreciated.


GlassWorks great with PIA. It has no conflicts.

Ok thanks again for the reply! I’ll take note. So it is the latest pia update.

1 Like