No Service installed


#1

Hi,
After uninstalling GlassWire and installing V2.1 on my Win7 PC, I got an error when starting glasswire : “The Glasswire service stopperd running”, but actually when I looked for that service to manually turn it on, it was not showing up at all. It was like it never got installed. I have no Firewall (except windows), no Anivirus and have disabled Malwarebytes.

Any one has any idea how to reinstall that service?

Thanks


#2

@Tricki

Can you uninstall in add/remove programs? Please do not use a third party uninstaller

Now reboot - IMPORTANT

Now reinstall our latest app using the “clean install” option.


#3

Hi Ken,

I have updated Windows, removed Glasswire and all the left over folders and rebooted. I then reinstalled Glasswire using the clean install option and rebooted again. None of this has reolved the issue the service is still not listed in services.msc

I also removed the antivirus installed and malwarebytes, just to be sure.

Regards

Richard


#4

Is it possible to try running Windows update on that PC and then try another clean install? With very ancient unupdated versions of Windows 7 there can be issues.


#5

I am runing windows 7?


#6

I think that @Ken_GlassWire means “Is it possible to try updating Windows 7” so it is up-to-date.


#7

I have, there are now more updates available


#8

Please continue to run updates if possible, then reboot and try a clean install once everything is updated.


#9

This has been solved. I finally got windows updates to finish all the updates after the SoftwareDistribution folder locked my permissions and stopped the updates.

I also removed both the antivirus (Panda) and malwarebytes. Glasswire started working again after these were reinstalled so I’m not sure if it was the updates or the re-install of said software that allowed the Glasswire service to be installed.

Hope that helps someone


#10

GlassWire works great with Panda and Malwarebytes, so I think it must have been related to Windows itself. Sorry for the issue and I’m glad it’s working now.


#12

Just tested latest 2.1 update:

  1. Software upgraded (uninstalled+install as single step: double click ‘GlassWireSetup.exe’ etc)
  2. Service gone (parts of windows say deleted, some don’t show it)
  3. Glasswire doesn’t work
  4. I rebooted, (depending on true service state step 2, this may not be required)
  5. Software reinstalled (install/maybe repair: double click ‘GlassWireSetup.exe’ etc)
  6. Glasswire does work

If it was a msi (windows installer/msiexec.exe) I’d be able to supply a log for debugging. Definatelly a glasswire installation bug within your installer.


#13

@dbareis

Could you click my name here, then send me the log?
Or, email it to me with a link to this thread?
https://www.glasswire.com/contact/

Thanks for this detailed report,but please note I have not seen many complaints about the installer. But even if there is a problem with a small percentage of our audience it hurts us so we should find the cause and fix it ASAP.


#14

IF there is a log then you’ll need to give me a clud as to where to find it and what it’s called.


#15

@dbareis

I apologize, when I saw “I’d be able to supply a log for debugging” I thought you had some kind of log you’d collected.

May I ask your OS version, and is it up to date with Windows Update?


#16

If it was a standard installer, I’d know where to get the log, I know that during installation a log is created at least within the UI, your installer then finishes and provides no access to the log. If its true that this doesn’t effect everyone then its easy to guess why it might effect some, for the same major bug that previously effected service startup, that is:

  1. You stop the service (in uninstall phase)
  2. You delete the service (in uninstall phase), either:
    (a) Without waiting for it to stop
    (b) Asynchronously (and therefore AFTER the install phase has “created” the service)

Whoever supports/creates the installer should be the one looking at this…


#17

What OS Version are you using? It will help me diagnose the issue.